IMA doesn't show any pictures in the viewer

Started by werner-k, June 04, 2019, 07:39:36 AM

Previous topic - Next topic



IMA worked as a charm, but then I created a new DB on my client PC (which uses German language) and copied that one to use it in IMA on my server-pc. When I open that DB in IMatch directly everything works fine. When I open it in IMA via the client-PC, the number of pictures is shown correctly in the navigator but no picture is shown in the viewer.
Can't get it to work anymore. Any idea what to try?

One thing to mention. I also upgraded IM and IMA to the latest version when it started to fail (2019.5).

Cheers Werner


Please always attach the IMA log files when you report problems.

See the IMA documentation for details and where to find them. ZIP the logs before uploading.

In the screen shot, nothing is currently selected so the file window is empty. This is correct.
Just select something in the Navigator first.

Note: You should make the Navigator a bit wider (with the arrow buttons at the bottom) to avoid it wrapping contents into a second row.


first of all, thx for the quick answer again!

there is one folder selected on the screenshot (called "Selects" with 44 pics, at the very bottom), but the menu bar at the top still shows "None".

This time I made the navigator bit wider, selected two folders and added the logfile (i also set option "Debug Info" to "Ausf├╝hrlich", before selecting the folders).

Hope that helps.


Nothing unusual int he log file.

Maybe try to select something else? A rating or label?
Stacked files visible?

Authentication enabled but user has no privileges to see the files?


I tried various things.
- installing version 04 again and creating new db with only one folder => IMA worked
- installing version 05 again and migrating the db => IMA worked

- but the DB with all my infos (that i restored from my laptop with relocation, ...) doesn't work in IMA.
- even when i removed all directories from the db and only added one directory again => IMA still didn't work.

so it seems that this DB was kind of "moved, configured, ...  to death" :(
will try to add all files again now and update this thread with the result... and hope that the problem won't re-occur...


I have no idea, sorry.

I don't recall a similar case and such things are very hard to diagnose remotely.
Check the info panel in IMatch Anywhere WebViewer (gear menu) to ensure that the proper database is open etc.

IMatch Anywhere usually "just works", which is one of the reasons why it's so successful.


well... thanks for checking nevertheless!

IM has a great deal of great options - especially the relationship-system is super perfect for me! - and I tend to try them all...
I also tried the DB-portability options with automatic relocation, and setting username alias, ...

So maybe I have found a not yet tested and unforseen combination of settings that is giving such problems.

I rebuilt the DB now from scratch, and currently it works again... like a charm! :)

Cheers Werner
P.S. still would love to find the problem, to avoid running into it again... so if there are any additional debugging options, ... I think I could find the time to try them too :)
e.g. I could also upload the - not working and almost empty db with just a few dummy pics inside ?


The only way to find what's causing this unique behavior would be to redo whatever settings, options, features you have used/activated/disabled until the problem shows again.

If you have database which produces this problem, send it to my support email address email or upload it somewhere and send me a link.
Maybe I can figure out why it's not working and fix the bug if it is one or maybe add a note to the documentation.


I have downloaded your sample database, thank you.

The problem was that IMatch WebViewer was unable to set a sort profile in the Web Viewer, and this caused the problem with the display.
After selecting an existing sort profile and refreshing the WebViewer with <F5> in the Browser, the files in the database show just fine.

I think this is a problem with the fallback mechanism when the default sort profile does not exist or a non-english version of IMatch is used and hence the Default sort preset is not named "Default". It is named "Standard" in case of your database - but that should of corse be not a problem. WebViewer does not look at the name of the sort profile to find a default sort profile for the initial run of a database.

I could not reproduce this here. Even after restoring the original database from your Pack & Go and resetting all settings. Very strange.

I need to check this for the next IMatch WebViewer update.


Figured it out!

The problem (as far as I can deduce from your description) happens when you use multiple databases with IMatch Anywhere.
When you select a sort profile for IMatch WebViewer and then switch to another database which does not have a sort profile with that name, IMatch WebViewer cannot restore the sort profile.
This causes the IMWS endpoint calls which retrieve data to display in the File Window to fail => no data in the file window.

I have now added a check for this and IMatch Anywhere WebViewer falls back to the default sort profile when this happens.

If you encounter this again before the next update is released, just select a sort profile from the drop-down menu and reload.


selecting a "sort-profile" works perfectly well for the culprit-db!
thx a lot for finding the solution!

cheers werner