IMA not working with non-PC clients

Started by suttonbg, September 06, 2023, 07:50:37 AM

Previous topic - Next topic

suttonbg

Dear Mario,

I have been using IMA across a home network with Win10 or Win11 PCs for a while now with no problems. Great product, very useful.

I have recently tried to use it with my " ├»ntelligent" LG TV, which is just smart enought to run a browser. Several iterations of IM and IMA ago and several updates to the LGOS for the TV, it used to work, but no longer. No problem, I thought to use an Android tablet I had handy and cast to the TV. No luck with the tablet  or an Android phone. All these devices showed the same result.

I am aware that in an earlier post (2017?), you advised that you were able to run IMA on an Android client.

Details:
IM ver 2023.2.4
IMA ver 2019.31.4

On Android, running http://SERVER-PC/info produces a positive result (text file with a lot of information).

On Android, I enter http://SERVER-PC/imatchviewer/ and this results in the IMA banner screen, with the message "Connecting to server...". The address bar had changed to http://SERVER-PC/imatchviewer/#!/init. There is no further progress beyond this point.

I have attached two log files, obtained after a reboot of the server-PC. For the file "..._Android ...", I attempted to open IMA on an Android tablet, which failed. After that, I closed IMA, extracted the IMA logfile and restarted IMA. For the file "...Windows...", I successfully used an Windows 11 PC as the client.

I'm not sure what other information I can provide at this point, but, as always, would deeply appreciate your assistance.

Kind regards,
Bruce Sutton

Mario

Which server address have you configured in your config.json for IMathViewer?
This looks like the IMatch Anywhere WebViewer cannot resolve the server address for some reason and thus cannot connect to IMWS. 

Which browser do you use on your Android device?

The IMWS log files do not help much, since nothing is logged (except from ExifTool warnings about invalid or unreadable data in some SR2 files).

Open the developer tools in your web browser with <F12>.
Switch to the Network tab and press <F5> to reload IMatch WebViewer.
Lines in read indicate errors and that will be the interesting information.
-- Mario
IMatch Developer
Forum Administrator
http://www.photools.com  -  Contact & Support - Follow me on 𝕏 - Like photools.com on Facebook

suttonbg

Dear Mario,

You were spot on. In my home network of PCs, I have made sure each machine was running the same localhosts file, with an exhaustive list of static IP assignments. That has worked, so I tend to forget about it. Hence my config.json file referred to the server by name. Changing that to a fully qualified URL (192.168...) fixed the problem. I assume the non-Microsoft devices cannot access this information and function quite happily using the external DNS for things like browsing etc.

This raises the question of whether it is worthwhile setting up a local DNS. I'm pretty sure my gateway router, provided by my Telco, doesn't allow this, so it may be a hassle for not much gain, if all I generally need is to remember one IP address.

For completion, the fault was (understandably) observed on both Firefox and Chrome. As well, I did learn how to remotely debug an Android device and you were right: the named PC host was unrecognised.

Thanks again,

Bruce

Mario

-- Mario
IMatch Developer
Forum Administrator
http://www.photools.com  -  Contact & Support - Follow me on 𝕏 - Like photools.com on Facebook

Carlo Didier

Concerning DNS: Your internet router should automatically function as an internal DNS server for your network by default. No need for localhosts files.
Maybe it will only do so for DHCP clients. Depends on the router.
If you want (like me too) always apply the same IP addresses to the same devices, you can use static assignments in the DHCP server of your router. No need for fixed addresses on the devices.