IMatch Anywhere doesn't start

Started by kai, April 10, 2021, 04:54:26 PM

Previous topic - Next topic



I'm trying the Trial Version of IMatch Anywhere but it doesn't start.
There's no IMatch running in parallel (made a copy of the database anyway).

I tried this on two different laptops and got the same error.

Kind regards


Looks like the IMatch Anywhere WebService could not start and Windows returned an error code.
This is a very uncommon failure.

Try this:

Reboot your computer
Retry to start the service.

If it still fails, check the Windows Event Log for error messages related (in the "Admin" section). There should be additional information why Windows could not start the IMatch Anywhere WebService.

The 1063 is a generic error and can mean many things.
Is this a corporate PC with security policies in place?
Did you try to change the user under which the service runs?
Has the service been properly registered? When you open the service manager (START > services) it should be listed there.
-- Mario
IMatch Developer
Forum Administrator  -  Contact & Support - Follow me on 𝕏 - Like on Facebook


Rebooting / Restarting didn't have any effect.
It's not a corporate PC but a private Laptop.

I tried it with a regular user and with an Adminstrator user.

The service is not listed in the services view (I guess the name begins with "IMatch").

The event viewer shows an error in the module ucrtbase.dll (see appended screenshots).

Best regards


This is a system component which is part of Windows. Not sure why it should crash when the web service is loading.
Maybe just uninstall and install it again.
Did your virus checker maybe interfere or even remove some of the components required by IMWS?
Usually IMWS "just works". Problems are so rare, I don't have more than a dozen entries in the support knowledge base, after two years...

The service should look like this in the services list:

-- Mario
IMatch Developer
Forum Administrator  -  Contact & Support - Follow me on 𝕏 - Like on Facebook


The service seems to run under a user "Besitzer" (the service log file is at c:\Users\Besitzer\...). But the database is located in an directory of user Kai. Is it possible that there is an access rights problem?
You could try to copy the database to some other (generic) folder just for checking.
Win 10 / 64, IMatch 2018, IMA


Moving the db to a generic directory like c:\temp_imatch_test\  didn't solve it.
But user "Besitzer" is an Administrator account anyway.


After all I installed Windows 10 on my computer (according to the download page
the prerequisite for IMatch Anywhere is Windows 7 Service Pack 1).
With Windows 10 everything is running smoothly and I have no problem starting IMatch Anywhere anymore.
So this is my solution for this problem.
Thanks for your help nevertheless.  :)