Author Topic: Categories imported OK but no pictures assigned.  (Read 1656 times)

rafiki

  • Jr. Member
  • *
  • Posts: 61
Categories imported OK but no pictures assigned.
« on: June 26, 2013, 10:57:26 AM »
I must have missed something somewhere. I followed the help files and imported my 3x categories. On importing to 5 the categories have all imported fine but although I had the 'assign' box checked nothing is assigned. After the initial import I do see a box saying another process is running 'so try later' with no indication what that process is. Often there is no task showing as active. Could the assign fail because of it?

Mario

  • IMatch Developer
  • Administrator
  • *****
  • Posts: 27441
Re: Categories imported OK but no pictures assigned.
« Reply #1 on: June 26, 2013, 11:09:59 AM »
I'm not sure where this "box" is coming from...was this shown by IMatch or by Windows?
IMatch may show a message box telling you that it is currently busy calculating something, e.g. categories after the import. Could it be this message?

Did you export the categories using the "with file links" format in IMatch 3?
Otherwise IMatch exports only the categories, but not the file assignments.

To assign files, IMatch must find them. Have you indexed the same files in IMatch 5 you have in your IMatch 3 database?

Note: You should not do that because you are working with a Beta version and there is always a risk of a undiscovered bug and data loss.

If you used other files, IMatch cannot re-create the category assignments when you use the By filename import mode. Switch to the by checksum mode.

Unfortunately you are not giving me much to work with.
The IMatch log file of that session would have been helpful.
The category schema file you have exported from IMatch 3 would have been helpful.
You can attach them to your posts.

Please see How to report bugs

Without that info, I can just guess...  :(



rafiki

  • Jr. Member
  • *
  • Posts: 61
Re: Categories imported OK but no pictures assigned.
« Reply #2 on: June 26, 2013, 11:23:49 AM »
I do apologise Mario. The last think I want to do is cause you extra work at this time. I felt it was just something I was missing and it was: when exporting categories I had not noticed the drop-down option '+ file links'.

Mario

  • IMatch Developer
  • Administrator
  • *****
  • Posts: 27441
Re: Categories imported OK but no pictures assigned.
« Reply #3 on: June 26, 2013, 11:44:38 AM »
Very good. Problem solved  :)