Various Problems

Started by OffPeak, January 09, 2020, 04:36:43 AM

Previous topic - Next topic


Maybe the common denominator with these issues is that I'm not a computer expert...
I've spent a fair amount of time searching for answers and threads, but have not found solutions.

1. If I open the Anywhere Browser, and click the http://computer:8081/imatchviewer/ on the Anywhere panel, it opens fine.
If I click a shortcut on my Chrome shortcuts bar, I get the error shown in attached file imatch_error_01.jpg.
(If I "Click or tap here to log in again" as instructed, it opens fine.)

The following issues only happen using Google Maps; OpenStreetMaps works fine (slower).
Everything worked when I first installed the Anywhere Browser, from my desktop, and laptop; these problems came up a couple of days later.

2. If I select the Maps View in the Anywhere Browser, I get the error shown in imatch_error_02.jpg.
(If I have the Maps View selected when I close Anywhere Browser, I get the error panel twice when I re-open.)
It can pretty much lock up the browser, with the little lockwasher spinning indefinitely.
I have created an Google Maps API.  Locating files, and the Map View, work fine in plain Imatch (haven't tried reverse geocoding yet).

3. If I clear history in the Anywhere Browser, select the Maps View, then select a group of files to display (let's say from Categories), I get what's shown in imatch_error_03.jpg.

Thanks in advance.


1. Show us the link.
I also use a shortcut in Chrome to open IMWV. Works without problems. Does your link perhaps contain parameters or an auth token? This cannot work later.
Create a link to the start page  http://computer:8081/imatchviewer/  always - without any ? or & parameters in it. This is most likely the problem. Check the actual link Chrome has saved.

2. You have not configured IMatch Anywhere correctly with your Google API key.
Google Maps is rejecting calls made by IMatch WebViewer.
You have to specify your API key in the WebViewer configuration file (config.json) because IMatch Anywhere is independent from IMatch. It cannot use the same settings as IMatch (usually it even runs on a different computer).

Open the help for IMatch Anywhere help (e.g. from the controller application with the Help button or <F1>).
Click on WebViewer Configuration at the top.
This page explains where the configuration file is stored and how to edit it. Make a BACKUP of that file before you make changes. Just in case.
Search for GoogleMapsKey on this page. Its one of the custom configuration options.
After entering your API key there, restart IMatch Anywhere WebServices via the controller and Google Maps will work just fine.

Let us know if you need detailed help for any of these steps.


1:  You are correct!
I saved the shortcut by clicking the star on the right of the "command line" in Chrome, and it had some extra characters.
I removed them, and the shortcut works fine.

2 & 3:  Fixed !  Works both on desktop and laptop.

Thanks again for your excellent support.
It is second to none !



Very good! Have fun with IMatch Anywhere.


I may actually be able to contribute something... a correction to the help screen.

You stated:
"Open the help for IMatch Anywhere help (e.g. from the controller application with the Help button or <F1>).
Click on WebViewer Configuration at the top."

The help screen states "imatchwebviewer" as part of the path to config.json; on my screen it is only "imatchviewer" !!!

See attached.
(Hope I'm right!)


Thanks. I will correct than for the next IMA release.