Resolution viewer

Started by javiavid, August 09, 2019, 10:17:15 AM

Previous topic - Next topic


I am trying to upload the resolution of the images in the viewfinder but I can't.
I have tried to change the image size in the configuration and put it to the maximum NHD or Large 1920, but I only see it bigger, but not with more resolution.
Cache images occupy about 10 Kb / image.


I'm not sure that I understand what you are trying to do.

Do you mean that IMatch Anywhere WebViewer does only show small images (maybe blown up to screen size)?

Are your original files on a different computer (server, NAS box)? If so, IMWS may be unable to access the files and thus fall back to using the thumbnails in the database.
This is because of the default "LocalSystem" account IMWS uses - this account cannot access resources on other computers.

Your Admin will see orange warning messages about this in IMatch WebViewer when he logs in to WebViewer and also in the Admin control panel.
See the corresponding section in the IMA documentation to learn about user accounts and which accounts to use to allow IMWS access to files on other computers. Just click on the "File Access (NAS and Server)" headline in the table of contents on the right.

And, always include the IMWS log file when you report problems. They contain important information. See "The Log File" in the IMA help for more information.


Yes, I have the orange messages.
The server is on a PC and the images on a NAS.

Drive / Media off-line: Note: If you run IMatch WebServices under the default 'LocalSystem' user account, it has no access to files and folders on other computers. See IMWS documentation for information about how to solve this.
Aug 9, 2019 2:11:38 PM (drive.unavailable)

And also of this type:

[Error 5] while creating a cache image. Tip: If this is a drive mapping to a remote server or a NAS, use an UNC path (\ \ server \ share older ...) instead.
Aug 9, 2019 2:13:20 PM (file.permissions)

When it refers to using UNC Path,
Is it the same to use // than // NAS1 / Multimedia?

I will try to configure it with the documentation and if I do not get it I will ask something more concrete again.
Thank you


QuoteDrive / Media off-line: Note: If you run IMatch WebServices under the default 'LocalSystem' user account, it has no access to files and folders on other computers. See IMWS documentation for information about how to solve this.
Aug 9, 2019 2:11:38 PM (drive.unavailable)

This error message explains your problem exactly.
Contract your IT people so the can advice.
If you are using IMWS in your home network and you are the Admin, follow the instructions in the help to setup a dedicated user account with network access privileges for IMWS. Or run it under your user account (consider security implications).


I am really trying to see the photos from the same PC that the server has.
Shouldn't I have the same permissions? (I am not an expert in networks  ;D)

If IMA is not accessing the original photos (when I try to download them in original quality, I get an error).
Where is the cache being generated, from the iMatch cache or from the iMatch thumbnails?
The iMatch cache generates 150 / 200Kb files, but the IMA cache generates 10-20Kb files.
How can I change to generate the cache with more resolution?


The error message indicates that IMWS cannot access the original files. So it cannot produce cache images at can only use the thumbnails stored in your database.
Include the log file in your replay. As explained in my initial reply to your question above.


I attached the log.
Thank you


IMWS tries to load files like

\\\Fotos\DESPUES\2016\viaje verano 2016\4 - Brujas, Gante\2016-08-22 13.18.27.jpg: Off-line or inaccessible.

and fails apparently. Do you use IP addresses instead of UNC paths in your IMatch database?
Has the "LocalSystem" account access to these resources? It does not look like it. Did you try to run IMWS under your user account for testing or tried the other measures explained in the help?


I have changed the route from // to // CH1, but it's still the same, I guess I'm missing the user theme.
I don't understand very well how it is done ..

I have been looking at the help of IMatch WebServices, but I think I lack computer skills to finish the installation.

Is there any video or documentation step by step to complete this process?


I have got it!
Thanks for the help


Quote from: javiavid on August 09, 2019, 11:07:09 PM
I have got it!
Thanks for the help

Excellent! What did you do to solve it?


-Change the path in the database, instead of using \\ 192.168 ... I am now using \\ CH1 \ ...

-Create a local windows user with administrator permissions.
-Access from the file explorer of this new user to the NAS using the password and activating the option to remember it.
-Use this user and password in windows services manually.

And with this no error message appears in imatch webviewer!
I have tried from Android and other computers and everything works correctly.


Good job! Have fun with IMatch Anywhere  :)