IMA not accessible by other PCs or IOS devices

Started by dadu, January 05, 2019, 11:50:23 PM

Previous topic - Next topic


Hello again,
I had this same problem back with earlier versions of IMA. I solved it back then by entering the IP address that houses the IMA services into the config.json (instead of the PC name) and it was working back then.
Now it is broken again using IMA 2019.
The config.json has this entry:  "imwsUrl": "" which is unchanged from before.
I can ping the server PC from other PCs on the LAN by it's name or IP address (can see shared folders, too); reply time is less than 1 ms.
Firewall settings are correct. (i.e., "Private" and "yes").
All PCs are on the same workgroup.
A DNS server is running on (my router).
The IMA WebService controller brings back valid info in the Service Info URL.

I am very much stumped why I can't get to IMA on any other device now...
I've tried by server name and IP, and neither work on any other PC or IOS device ( and http://MYPCNAME:8081/imatchviewer).
In either case, it says "This site cannot be reached... (or MYPCNAME) took too long to respond.

I stopped all services, deleted the config.json, reinstalled as a repair, and then rebooted. No change.

What am I missing?


Make sure you end the url with a backslash:
But that has not changed from before, either.

Which error message do you get?
Does WebViewer not open at all or does it not get a connection to IMWS?
Can you access WebViewer from Windows PCs? Try on the computer running IMWS. If that works, the installation and settings are OK and its just one of those MacOS / iOS network issues.
-- Mario
IMatch Developer
Forum Administrator  -  Contact & Support - Follow me on 𝕏 - Like on Facebook


Hi Mario,
- yes, I've added the ending backslash on other PCs; no change.
- No, I cannot access the WebViewer from other PCs (non-Apple computers ), even though I can  ping the server (by name or IP address) and see all shared folders on it from those PCs.
- On those PCs it says "This site cannot be reached...the site took too long to respond"

Was I supposed to uninstall the previous version of IMA before installing IMA 2019?

It's really frtistrating that this is not working from any other PC, since it works fine on the host PC.

I have disabled Windows Defender and Avast antivirus on the host PC and tested. No change

Any other suggestions?


If you can successfully access IMatchWebViewer on the PC running IMWS but not from your network,

either the IP address has changed or something is blocking access from your other PCs. And this would be most likely the Firewall on the PC running IMWS.
-- Mario
IMatch Developer
Forum Administrator  -  Contact & Support - Follow me on 𝕏 - Like on Facebook


Okay, the issue is resolved!
I updated the firmware in my router and then the Webviewer was immediately accessible on all other devices; both PC and Apple devices.
Not sure why that was the fix, since the firmware on my Asus router was only one version out of date.