Anywhere on a Mac: problem viewing full sized pictures

Started by Emile, March 31, 2018, 04:01:36 PM

Previous topic - Next topic



First of congratulations! I just tried iMatch Anywhere on my Mac and after adjusting the config.json file it runs smoothly and is very fast (at least on the local network). However, I ran into a problem trying to look at a full sized image rather than a thumbnail. The message I get is: "Cannot access one or more files in the folder 'P:\ Work\ UK\ ' ('xxxx.jpg') [Error 3] while creating a cache image. Tip: If this is a drive mapping to a remote server or a NAS, use an UNC path (\ \ server\ share older...) instead. Mar 31, 2018 3:05:24 PM (file.permissions)."

My images are on a NAS, so where should I use a UNC path instead of a mapping?


Hi and welcome!  The UNC path should to be used in the main IM database that is used for IMA if you are going to access DB info from across the network... so, all images should be referenced using the network drive rather than the shared or mapped drive letter.  Please see this document for more info:



IMWS cannot access the images on your NAS system.
There should be corresponding messages in the event log and the log file.

Like all services running under the LocalSystem account, IMWS cannot access resources (files) on other computers. IMWS has no access to the files on your NAS system. Windows prevents that.
To allow IMWS to access files on other computers or your NAS you need to change the user account under which the IMatchWebServices service runs to a user account which has access to remote resources.

Please see the corresponding topic in the IMatch Anywhere Documentation. Press <F1> or click on Help in the WebService Controller.
After the documentation has opened in your web browser, click on the File Access (NAS, Server) entry in the table of contents on the right.
This explains what the problem is and how to change the service configuration to allow IMWS to access files on your NAS.

I also recommend the IMatch Anywhere Knowledge Base for answers to frequently asked questions.



Hi Mario,

I just tried it without much success. I assume that by "To automate this step you can use the corresponding options in the Advanced Options dialog. Specify a user name and password and the Controller application configures the service automatically." you mean the advanced options in the iMatch Web Service Controller? If so, that is where I went and I added the server's account name and password under "Service User account" and "Password", saved and ried to start IMWS but was greetd with an error message: "The service failed to start..." "The service did not start due to a lonon failure. [1069]"


Please always include the log files IMWS produces. You can find them in the TEMP folder on your system. See the IMatch Anywhere documentation for details about how to find and use the log file.

QuoteI added the server's account name and password

If Windows fails to start the IMWS service, probably the user name and password you have provided is not a valid Windows user name / password.
If you (with your Windows log-in name and password) can access the NAS, you can use the same credentials for IMWS. Or did you use some use name password you use on the NAS? These cannot work, because Windows does not know them.


Log file attached. I should note that even when I remove the requested info IWSC now refuses to run (service can no longer be started).


When you try to start the IMatch WebService from the Windows Task Manager or the Windows Service Manager (see IMatch Anywhere documentation for details) Windows should either display an error message or log an error to the Windows event log that tells you why it is no longer working.

I suggest you open the Windows Service Manager and there locate the IMatchWebServide. Right click, properties. Enter a valid Windows user name and password (yours, if in doubt).


Ok, thanks. I set it up in Windows Service manager and that seems to have solved the problem. Using a UNC instead of a drive mapping subsequently solved the image loading problem too.

I take it is probably a good idea to let the Windwos service run on start-up?


UNCs are mandatory (see IMWS documentation, extra point on that) because Windows manages drive mappers per user.

QuoteI take it is probably a good idea to let the Windwos service run on start-up?

This depends on whether you always want to run IMWS or not.