Newly imported mage won't show in Media & Folders Panel

Started by BanjoTom, August 13, 2017, 09:49:16 PM

Previous topic - Next topic


Today I imported/indexed a .jpg photo today (as I've done hundreds of times before), but for some reason this one image does NOT show up in the "Media & Folders" view.  In that view, I use a folder structure that is named for the year and month, and I rename most files with the Renamer so that they have names like YYYY-MM-DD-000x.ext.   

I'm puzzled why the image on the LEFT in the attached view won't show up in "Media & Folders", though all the other images in that folder -- like the one on the RIGHT (dated one day later) -- do.  There is no "Protection" on either image, no filters are in operation, and I can find both of them in the Category Views, or in the Timeline, or (now that I marked them both with a green pin) in Collections.  In those views, searching for words used in the description field will find either image, but that does NOT seem to work to bring up the image on the left in the "Media & Folders" view.  And in the Collections view, they both work perfectly in the Viewer and/or QuickView.  Sort order also does not seem to make any difference within "Media & Folders."

What am I missing? Any suggestions about why this ONE .jpg image won't display in the view of "Media & Folders"?

Bound to be something very basic that I've overlooked . . .
— Tom, in Lexington, Kentucky, USA


Just two ideas (well, wild guesses...):
Did you check that the image has been imported into the correct folder? Please check the "File Folder" in the Metadata browser. Or select the image in the collections view where you find it and press Ctrl-G to jump to the Media&Folders View. What happens then? Does the image simply disappear?

Second point to check: Is some "Folder Filter" active in the Media & Folders view?

Win 10 / 64, IMatch 2018, IMA


Or perhaps it's a bug because I had this very same problem yesterday.  Below are the notes I made at the time on how I managed to resolve it.

And at the end of this I've attached the results of the first diagnostics I did.  I'm afraid I didn't save the log file because at the time I wasn't sure if I had a problem or was doing something wrong.  So Tom that would probably be a good idea for you to attach your log file for Mario to check it.

Here are my notes from yesterday:

Saturday, August 12, 2017
The !Queue folder was only showing one new imported photo (jpg) when there were 3 new JPGs in the folder.  Moved the JPGs to a different folder but they still wouldn't display.  Ran database diagnostics and it found problems and fixed them.  Ran diagnostics again and no problems were found but the !Queue folder still only showed one image.  It was like a filter was active yet no filters were active.

Restarted IMatch, but still had the same problem.

Ran diagnostics one more time, no problems were found, but afterwards the !Queue folder showed the 3 images like it should have all along.


Thanks for the suggestions, but -- I've run Database Diagnostics multiple times, to no avail.  I am using Window 10, and Imatch 2017.8.2, 64-bit. 

I have restarted IMatch -- no help there.  No folder filters are active in the "Media & Folders" view.  If I find the image in the Timeline view or the Collections view and choose Ctrl+G (Go to Folder), I am taken to the proper folder in "Media & Folders," but the image is still not visible.  The image file DOES show up in Windows Explorer when I look into that folder. 

I've looked in the Metadata panel under both "Browser" and "Default" but don't see where either of those views shows an entry for "File Folder."  When the image is selected (in Timeline or in Collections), the listing at the very bottom of the screen does show the proper folder and filename -- but I simply cannot make that image display from the "Media & Folders" view.

I'm stumped.

— Tom, in Lexington, Kentucky, USA


One more observation: If I hover over the folder in "Media & Folders" view, I CAN see the missing image within the reduced-size view of the first few images in that folder; but it still doesn't show up in the actual "Media & Folders" view, regardless of how I sort or display the files contained in that folder.  I've highlighted this effect in the attached screen-capture, where you can see the missing image (circled in red) at the left, but it is NOT showing up amidst the normal thumbnails at the right.   

Mario -- or anyone else -- any suggestions?
— Tom, in Lexington, Kentucky, USA


Well then for sure you want to attach your log file to your next post so Mario will have something he can analyze.


Should that be a "nomal"  log, a "full log," or a "debug log?"  And since IMatch is now closed, what actions should I try to carry out once I've got the right type of logging being recorded? 
— Tom, in Lexington, Kentucky, USA


I'd either go full logging or debug logging, not sure which would actually be best in this situation.  Then after you've used IMatch again and have verified the problem still exists go to Help > Support > Copy Application Log file to save it.  After you've saved it, zip it and attach it to a post here.

I've used IMatch for over 11 years now and yesterday was the very first time I've had a problem like this, that's why I suspect it might be a bug.


+1 here!
  Of 8 images only one showed up, though the count for the folder in the left pane showed 8. Erased, tried to drag in the 7 that did not show at first, the importing window opened and when finished, nothing there. Then I dragged in, in addition, the one that previously was showing up, and magically the rest of them appeared as well. No idea why and how.
Regards Emil


Yes, I have encountered this as well. But I have other ingesting problems - reported elsewhere - also.
And frequently some thumbnails don't show until I do a forced rescan.


Do you perhaps use stacking or versioning?

If the image is visible in the tooltip, you can use goto to go to the folder, IMatch has indexed the file properly.
The only way it would not show up in the file window is:

1) Search Bar active
2) Some filter active
3) Stacking
4) Version Stack

Did you check for all these potential reasons?

Switch to a file window layout which shows icons so you see if the file is part of a stack.
Clear the search bar.
Activate (pause) the filter panel, just in case.


Mario, I've tried ALL the methods you suggested, but the image is still not visible in the Media & Folders view.   
— Tom, in Lexington, Kentucky, USA


I had this two or three times.
But it had alway to do with Versions and stackings.

So, this is not the case, if I understand you correct.
Best wishes from Switzerland! :-)


Markus, the only versioning I use (as set in Preferences) is a link between Photoshop .PSD files and derivative .JPG files, but that is not the case with this one problem image -- it came to me as a .JPG file and remains in that format.  I never created a stack involving that file either, and nevertheless I've tried (when I load that file in any view other than "Media & Folders") to UNstack it -- no result.

I remain completely puzzled.  The image obviously WAS ingested and indexed, but it just won't show up in "Media & Folders."  The folder it's contained in shows that there are 46 files in that folder, but I can never get more than 45 of them to show up in the File window. (see attached image, with red highlights showing the discrepancy).

— Tom, in Lexington, Kentucky, USA


I've set logging to "Debug," and have attached a zipped version of the latest log.  Maybe Mario or someone else will see something here that can help me solve this problem.  THANKS to all!
— Tom, in Lexington, Kentucky, USA


1. Disable the hierarchy view (just in case).
2. Do you open the folder from your folder favorites list or the media & folders tree?
3. Select all files in that folder and press Shift+U. When asked, choose "Delete Stacks". Maybe the file somehow got stacked with a file that is in the scope in this case...
4. Select all files and press <T> to toggle version stacks.
(Your screen shots don't show icons so I cannot tell if your files are stacked or versioned).

I have no idea why the file window would hide one file...

The files in the folder are loaded. Files hidden by stacks  and stacked versions are removed.
The filter panel is applied.
The search bar s applied.
All files remaining are shown in the file window.

Something in this process (which is unchanged for a long time) seems to hide your file...


I tried EVERY step that Mario suggested in his last reply, and none of them worked to make the problem file visible in "Media & Folders" view.

So -- since I still had my brother's email with the attached photo in question, I deleted the "problem version" of the file from IMatch.  Immediately after that, the number reported in parentheses in the Media & Folders menu once again matched the number of images visible in the File Window.   :)

Then I re-imported (indexed, ingested) the same photo file (a simple .jpg created on my brother's iPhone 6s), and made changes to its name and all other metadata ONE step at a time, writing back the metadata after each change. 

Now the file shows up properly in ALL four main views, and seems to be acting the way all my other files (about 65,000 in all) normally act.

So I've solved the immediate problem, but only by brute force.  I still have NO IDEA why the previous version of this one file was never visible in "Media & Folders."   :P

Thanks to all who offered suggestions, though! I am always grateful for the wonderful support offered by Mario and all the dedicated users of this forum. 
— Tom, in Lexington, Kentucky, USA


We need to find a 'repro case' for this to do anything about it.
When you happen to find steps which produce this result, let me know. If I can reproduce it, I can fix it.

PS.: This is the board or IMatch Anywhere, not IMatch.


Oops, sorry for posting this in the wrong board in the first place . . .  :-[ If the problem recurs, I will definitely post again, and in the RIGHT board!!!  Thanks, Mario . . .
— Tom, in Lexington, Kentucky, USA


Quote from: Mario on August 14, 2017, 08:48:18 PM
PS.: This is the board or IMatch Anywhere, not IMatch.
Oops! I never noticed; my happening was in IMatch per se. Can't reproduce the prob, either (yet? so far it has not come back ...)

Regards Emil