IMA: Keywords not displaying

Started by Jingo, May 30, 2017, 06:29:49 PM

Previous topic - Next topic


Hi.. I just witnessed a strange thing and I'm not sure how to figure it out.

Just upgraded both IMA and IMatch 2017 to latest versions.  Imported a bunch of new images to IMatch and added keywords.  Saved the metadata back out to the images.

Turned off IMA service, copied the IMatch DB to the IMA DB, turned on the IMA service...

Lauched IMA via firefox and using the timeline, verified my new images show.. great I thought!  However, no keywords for the new images are displaying... I verified the keywords show correctly in the IMatch DB and I verified the images are correct on the disk via Exif Pilot.. screenshots below.. any thoughts?



Exif Pilot:


Made a quick check and it works on my dev PC and the "user" PC. No problems.

Looking at the keywords on disk is not a good test. Did you look in IMatch in the Keywords panel to verify that these files have keywords in the database?

-- Mario
IMatch Developer
Forum Administrator  -  Contact & Support - Follow me on 𝕏 - Like on Facebook


Strange.. I think the problem was my copy method... the scheme I was using to shut down and restart the service appears to not work... so the imd5 file was being copied from IM to IMA with the services running still.. (I thought this would prevent the copy but I guess not).  Strange that the images appeared... but the keywords did not.

In any event, I manually shut down the IMA service, manually copy/pasted with overwrite the imd5 file and then manually started the service ... and the keywords now appear correctly.

I guess I'll have to forego the automation because I just cannot get the services to stop/start on my system except manually... I always get UAC access problems to the scripts I wrote, my exe's from bat's I created, etc.... I have been tweaking UAC for days now and no matter the settings... I still can't seem to get permissions set correct for these service shutdowns...

Oh well... sorry for the bother Mario... all good here now!