Author Topic: Windows 10 (Anniversary Update and WIC)  (Read 641 times)

Erik

  • Sr. Member
  • **
  • Posts: 286
Windows 10 (Anniversary Update and WIC)
« on: September 23, 2016, 07:22:19 PM »
This isn't a question just a statement of some findings regarding an apparent problem, which was ultimately caused by Microsoft. Please read the whole message before replying (I doubt anyone will need to). 

New baby in the house so I hadn't cataloged files with IMatch since late July.  In mid-August, my computer updated itself to the Windows 10 anniversary addition, and yesterday was the first time I tried IMatch (5.6.22) since the update.

Well on importing some new photos, I had no thumbnails and IMatch struggles to read any metadata.  I should say that some photos were shown on the initial scan (I call them the fuzzy thumbs) and promptly disappeared on completion of the scan.  IMatch also made a dump when I exited.  I didn't save the logs as my first thought was this was a Windows problem (and possibly a codec problem). Tried a few restarts with no change in behavior.

So I updated to 5.7.2.  IMatch was stable, but still no thumbs after rescan (all metadata was read in though).  Next step was the check WIC.

Apparently the update to Windows corrupted the FastPictureViewer codec pack. 

I tried repairing the installation, which failed because of a corrupt file.  The solution:

1. Uninstall the FastPictureViewer codec pack.
2. Reboot the computer. 
3. Reinstall the codec.
4. Reboot the computer
5. Start IMatch and force a rescan of all the new files. 

Problem solved.

Other notes... this may be a problem because I use a Pentax camera, which is not well supported by Microsoft's own codecs.  This could also have just been a problem because of my computer itself.  Ultimately, it was not a IMatch problem, but I wanted to post this because someone may have the issues and think it's an IMatch problem.

Mario

  • IMatch Developer
  • Administrator
  • *****
  • Posts: 29760
Re: Windows 10 (Anniversary Update and WIC)
« Reply #1 on: September 23, 2016, 07:31:57 PM »
I also use the FPV codec pack and I installed the Anniversary Update. This did not affect my FPV installation (I just checked some PEF files because you mentioned that you use Pentax cameras).

Given that there are 1.25 billion Windows PCs out there, with probably millions of different configurations of hardware and software, it's just likely that some things may fail on some computers. There is always an odd chance that some virus checker interferes, a partially damaged (by whatever) Windows update database causes confusion or corruption during an upgrade etc.  Really tough all that.

Usually strictly maintained systems (e.g. in large companies) are less affected than computers run by normal folks, with a plethora of installed software, drivers and running on a massive variety of hardware components.

You may have just run into a problem that does not thankfully affect many users. But thanks  :) for sharing your solution. It may help other users with the same problem.


Erik

  • Sr. Member
  • **
  • Posts: 286
Re: Windows 10 (Anniversary Update and WIC)
« Reply #2 on: September 23, 2016, 07:47:21 PM »
I should also add that I shoot using DNG files from my Pentax Cameras (not generated by Adobe in any way).  This too could also be part of the problem.  Windows may in fact be confused by the DNG file and perhaps tried to use the wrong codec.  In all honesty, I ran across this late at night, so I didn't really check too hard with IMatch as I automatically assumed it was a Windows problem.

I haven't even checked this yet on my desktop, which might be quite telling.  I suspect it might be something very specific to my setup. 

I have to say that 90% of the issues I've ever had with IMatch (and even some other software) has been a result of WIC, which may be an issue with the DNG files my camera generates, mostly in the past couple of years.  I suspect it could be Microsoft (since Windows 8) or even Pentax. I got a K3 in the past few years and perhaps the DNG from that camera is just different enough from the DNG from my previous cameras.  A side note, I should probably go back to PEFs but I originally used the DNGs as I actually preferred having the XMP within the files to just keep things cleaner (I didn't like the idea of all those xmp files at first).

I suppose there is a chance Adobe is also messing things up.  It wouldn't surprise me if there is an Adobe codec in the mix, which may be interfering.  I'm not exactly sure how Windows picks a codec if there are multiple (valid) codecs for a file type.  I used to explicitly turn off Microsoft and Adobe's codecs, but I haven't done that in this case (if it's still possible).

ubacher

  • Oldtimer
  • ****
  • Posts: 2358
Re: Windows 10 (Anniversary Update and WIC)
« Reply #3 on: September 24, 2016, 03:17:05 PM »
I had this issue and reported it in
https://www.photools.com/community/index.php?topic=5829.msg40146#msg40146[/i]

also after the Anniversary update.
I don't recall the details now but I ended up uninstalling the update because Imatch was unusable (could not get new images working).
( The update had fixed some problems I had with my 4k display so I have been
struggling since then with display problems and waiting for hopefully a future fix - by MS or Imatch - whichever.)

I am working on the laptop now and will be for many weeks/months so the pressure to get the Anniversary update
working is off at the moment.

loweskid

  • Full Member
  • **
  • Posts: 195
Re: Windows 10 (Anniversary Update and WIC)
« Reply #4 on: September 24, 2016, 08:57:44 PM »
I had the anniversary update today - no problem with codecs but IMatch was hanging as soon as I opened the database.  I had a similar problem in the past which was caused by the Adobe Bridge cache files so I tried loading Bridge and sure enough that was hanging as well as soon as I clicked on a folder that contained images that I had recently been working on.  I deleted the Bridge cache folder then searched for and deleted anything related to the Bridge cache.  It seems to leave a file called 'BridgeSort' in each folder and I think this is the problem file - I assume IMatch will be trying to read it as well.  Anyway, after deleting the cache and all these BridgeSort files all is well.

Edit - everything was working fine before the Windows update and I don't see why it should have screwed things up - but that's the wonderful world of Microsoft/Adobe, always full of surprises..!
« Last Edit: September 24, 2016, 09:00:30 PM by loweskid »

Erik

  • Sr. Member
  • **
  • Posts: 286
Re: Windows 10 (Anniversary Update and WIC)
« Reply #5 on: September 27, 2016, 07:37:29 PM »
I'm having odd issues here and there with multiple software.  In many cases, I've been able to repair the installations (through the control panel).  With IMatch, I hadn't installed 5.7.2, so I did that and Imatch was fixed.  I was having odd problems, but I didn't log them just assuming I needed to reboot my computer and attributing them to Windows.

In one or two cases (the FPV codecs was one), I had to uninstall and then reinstall the program.  All I can figure is Windows may have altered some of the dll files or even drivers that were there prior to the update.

As for IMatch, prior to updating to 5.7.2, I had an issue importing images into IMatch.  The folders were being imported, but the metadata was not scanned in, and I couldn't refresh the metadata.  Closing IMatch caused a crash.  I had no thumbnails, and the quick-viewer would show files randomly. Fresh out of the camera, some images would show and others would not. 

Again, I had installed the Windows update almost immediately beforehand, so I assumed it was Windows. After reboots did nothing, I then updated IMatch.  The metadata then read in fine, but I still had the thumbnail and viewer issues.  The WIC fix I started this thread with fixed everything.

Users who are having problems might consider trying to repair their install of IMatch if they are already at 5.7.2.