Author Topic: WIC codec required  (Read 1093 times)

cthomas

  • Sr. Member
  • **
  • Posts: 472
WIC codec required
« on: April 10, 2016, 05:41:00 PM »
Every time I try to Import my database I get this error see image. How can I fix this? The data base just has about 72,000 images running on Windows 10.

[attachment deleted by admin]
Carl

Montana, USA
The Big Sky State

Mario

  • IMatch Developer
  • Administrator
  • *****
  • Posts: 29760
Re: WIC codec required
« Reply #1 on: April 10, 2016, 05:57:46 PM »
You are adding PDF files and IMatch cannot find a WIC codec for PDF files on your system.
Install one. Or mark the "Don't show again option" in this box.

cthomas

  • Sr. Member
  • **
  • Posts: 472
Re: WIC codec required
« Reply #2 on: April 10, 2016, 09:47:49 PM »
You are adding PDF files and IMatch cannot find a WIC codec for PDF files on your system.
Install one. Or mark the "Don't show again option" in this box.

Mario I just bought FastPictureViewerCodecPack. What is the best way to install it so it will work with IMatch 5 the best?
Carl

Montana, USA
The Big Sky State

Mario

  • IMatch Developer
  • Administrator
  • *****
  • Posts: 29760
Re: WIC codec required
« Reply #3 on: April 11, 2016, 08:06:20 AM »
Just install it normally.
If you work with certain RAW formats, check the options of FPV to make sure that they are to your liking (e.g. embedded preview usage).
I would also disable the feature to automatically rotate images based on EXIF data in FPC. This causes problems with applications like IMatch which rotate images themselves.

cthomas

  • Sr. Member
  • **
  • Posts: 472
Re: WIC codec required
« Reply #4 on: April 12, 2016, 05:55:32 PM »
Just install it normally.
If you work with certain RAW formats, check the options of FPV to make sure that they are to your liking (e.g. embedded preview usage).
I would also disable the feature to automatically rotate images based on EXIF data in FPC. This causes problems with applications like IMatch which rotate images themselves.

Is this the FPV you are talking about(see image)? "I would also disable the feature to automatically rotate images based on EXIF data in FPC. " Where is this?



[attachment deleted by admin]
Carl

Montana, USA
The Big Sky State

Mario

  • IMatch Developer
  • Administrator
  • *****
  • Posts: 29760
Re: WIC codec required
« Reply #5 on: April 12, 2016, 06:04:10 PM »
It can only be selected during installation when I remember correctly. I suggest the FPV web site and documentation to answer this question.

cthomas

  • Sr. Member
  • **
  • Posts: 472
Re: WIC codec required
« Reply #6 on: April 13, 2016, 02:39:45 AM »
It can only be selected during installation when I remember correctly. I suggest the FPV web site and documentation to answer this question.

I uninstalled the WIC codec and reinstalled it but I didn't see anything.
Carl

Montana, USA
The Big Sky State

Mario

  • IMatch Developer
  • Administrator
  • *****
  • Posts: 29760
Re: WIC codec required
« Reply #7 on: April 13, 2016, 09:07:12 AM »
The last time I installed FPV it was there. Please consult the FPV documentation or contact FPC support.

DigPeter

  • Super Hero
  • ****
  • Posts: 1238
Re: WIC codec required
« Reply #8 on: April 13, 2016, 01:27:48 PM »
I uninstalled the WIC codec and reinstalled it but I didn't see anything.
Early in the install process you are given a list of items that can be changed.  At the top is the one you want - about rotating images.  I had 2 attempts before I saw this.

Aubrey

  • Super Hero
  • ****
  • Posts: 1316
  • IMatch user since June 2008
Re: WIC codec required
« Reply #9 on: April 13, 2016, 03:20:10 PM »
I tried to find it this morning, by uninstalling and reinstalling (and doing the recommended reboots), so as to help cthomas. I did not see it, though I knew it was there! I finally gave up!  :-\

I'd better do another install and look very carefully. ;)

Aubrey.

cthomas

  • Sr. Member
  • **
  • Posts: 472
Re: WIC codec required
« Reply #10 on: April 13, 2016, 06:07:22 PM »
I tried to find it this morning, by uninstalling and reinstalling (and doing the recommended reboots), so as to help cthomas. I did not see it, though I knew it was there! I finally gave up!  :-\

I'd better do another install and look very carefully. ;)

Aubrey.

Good morning Aubrey. I appreciate your help. I'm something "I'm blind in one eye, and can't see out of the other eye."

Carl
Carl

Montana, USA
The Big Sky State

Aubrey

  • Super Hero
  • ****
  • Posts: 1316
  • IMatch user since June 2008
Re: WIC codec required
« Reply #11 on: April 13, 2016, 09:20:05 PM »
Well, I did another install.. Looked carefully at almost all the options, and didn't see comment to not use Exif. I'm using version 3.8. I wonder if the switch was on an earlier version. So I give up! I'll worry about rotation now on a case by case basis.