csv-import to attributes seems to work but no attributes are visible

Started by kkiel, February 29, 2016, 09:48:32 AM

Previous topic - Next topic

kkiel

Hi everybody,

I'm trying to import data from a csv-file to attributes. The import dialog looks fine, I can link file number and wanted csv-column with IMatch attribute. IMatch shows 'import finished' after that but I can't find the wanted info in my attributes. Maybe this is so because the attribute set exists but there are yet no rows ('Datens├Ątze) belonging to the image? I wanted to create them by making the import.
Or can there be another reason for this? It looks so straightforward but my data simply doesn't reach it's destination ...
I use a google-made csv-file (no hidden excel formats). It doesn't work whether I mark the images I want to add attributes to or not.
Thanks for any help!

kkiel

Mario

You can try several things:

1. If you want to import 'per file' attributes, have you indicated the column in your file which contains the fully qualified file name? Can IMatch find the files?

2. IMatch reports not only that the import has finished, but also how much data was imported. What does it say?

3. Open the output panel (<F9>,<O>) and switch to the script tab. The import script may report problems there.

To help you, we need more into than you provided:

4. Show us a screen shot (<Alt>+<PrintScn>) of the CSV Import dialog with your settings.

5. Attach a sample CSV file you are trying to import.

6. Export your Attribute Schema via Edit > Preferences > Edit Attributes, Export... button. We need only the schema, not your data.

kkiel

Thank you, Mario, for your answer.
I found it now: The images I wanted to import metadata into where offline, which I though was ok since I wanted to import data into attributes which are IMatch-specific and not written into the image itself.

Mario

Strange. The script does not check if a file is on-line or something. Neither does it access the physical file on disk. In only looks in the database if it can find the file by the full file name, not in the file system itself.

kkiel

Hi Mario, I tried it again some days later (same filenames) and this time it worked with having the data files offline. I seem to have some other issue here and will open another thread for that: https://www.photools.com/community/index.php?topic=5390.0
Thank you!
kkiel