Deleting keyword doesn't work, probably when containing Comma

Started by jer, August 04, 2015, 02:52:26 PM

Previous topic - Next topic


Using trail version of IMatch5 (5.4.15).
When I delete keywords using the GUI this normally works. Except some keywords, probabelly when containing a comma (e.g. "050819 Kassianspitze, etc"). This seems to reappear when rescanning files (cause it wasn't actually deleted in the jpg).
Any suggestions?


I can delete keywords containing commas without a problem.

We thus need more info about what you do exactly.

Where do you delete the keyword?
Do your files contain legacy IPTC and XMP data?
Do you use non-standard XMP->IPTC mappging settings?

Which list separator do you use in Windows?
By default this is ; for US systems and , for German Systems. Maybe when you use , in your keywords and also , as the list separator on your system you create a situation where IMatch cannot tell whether , is a list separator or part of a keyword? And this is then what causes the problem on your system?

Which separator characters have you configured for keyword import under Edit > Preferences > Metadata?
-- Mario
IMatch Developer
Forum Administrator  -  Contact & Support - Follow me on 𝕏 - Like on Facebook


Thanks for your hints. I actually use a special setting concerning list separators, on a german system I changed the list separator to comma (and decimal separator to point). thus like an english system. I've tried to change the "keyword separator" setting in Preferences Metadata from ";" to ",", then it works. Thanks for your help.