Author Topic: Annoying detail when writing keywords  (Read 1180 times)

emef

  • Full Member
  • **
  • Posts: 151
Annoying detail when writing keywords
« on: August 11, 2014, 05:06:36 PM »
Hello everyone,
I noticed a detail (annoying) when writing keywords: when I assign a keyword, I check out the "V" green and yellow pencil appears in the photo.
So I click on the pencil Imatch am told he writes the data well, the yellow pencil ... disappear to reappear a few seconds later. I have to click a second time this pencil
(and Imatch gives me the same confirmation message writing) so that the pencil disappear permanently (at least until I change the data). It's infuriating!   :(

TIA.

Erik

  • Sr. Member
  • **
  • Posts: 286
Re: Annoying detail when writing keywords
« Reply #1 on: August 11, 2014, 05:19:17 PM »
This is an often discussed behavior.  For MWG compliance, IMatch writes the Hierarchical Keywords and then checks whether the related flat Keyword fields are consistent with the thesaurus.  This mapping (propagation) of keywords between the hierarchical and flat keyword fields often takes two write processes.

-Erik

emef

  • Full Member
  • **
  • Posts: 151
Re: Annoying detail when writing keywords
« Reply #2 on: August 11, 2014, 06:38:59 PM »
Thank you for your answer, but does this mean that we need whenever double click on the pencil, there is no way to automate this?     :-[

Erik

  • Sr. Member
  • **
  • Posts: 286
Re: Annoying detail when writing keywords
« Reply #3 on: August 11, 2014, 06:48:57 PM »
Thank you for your answer, but does this mean that we need whenever double click on the pencil, there is no way to automate this?     :-[

I don't know of a way to automate this, and this behavior has been ongoing for quite a while.

My own solution to this issue is to utilize the keyword propagation button that is in the keywords panel (next to the thesaurus icon with an orange arrow).  This forces IM to propagate the hierarchical keywords to the flat keywords prior to writing anything.  When I do that step, the metadata write-back succeeds in one operation.  The yellow pencils go away in one click.  This is a bit more efficient than clicking the yellow pencil twice since you are only writing metadata to your files once.


Mario

  • IMatch Developer
  • Administrator
  • *****
  • Posts: 28790
Re: Annoying detail when writing keywords
« Reply #4 on: August 11, 2014, 06:53:37 PM »
Updating keywords does not require two write-backs (normally).
This is just a straight-forward process. You change hierarchical keywords and IMatch writes them to the file, propagating the keywords to both flat XMP and (optional) IPTC keywords - depending on the file format used, the metadata settings etc.

A typical reason for "new" keywords being generated (thus causing a second write-back) is either a mismatch between the existing legacy keywords in the file, or the settings you have made for importing and flattening keywords.

Where do you edit keywords?
Which file format are you using?
Do you files contain legacy IPTC data?
Which keyword import options do you use under Edit > Preferences > Metadata?

emef

  • Full Member
  • **
  • Posts: 151
Re: Annoying detail when writing keywords
« Reply #5 on: August 12, 2014, 12:47:20 PM »
Updating keywords does not require two write-backs (normally).

(snip)

Where do you edit keywords?

In the "thesaurus manager"

Which file format are you using?

Nef, Jpeg and Tif

Do you files contain legacy IPTC data?

I presume     ;D

Which keyword import options do you use under Edit > Preferences > Metadata?

See attached file




[attachment deleted by admin]