IMA not updating database content

Started by suttonbg, April 26, 2024, 12:43:12 PM

Previous topic - Next topic


In the last week, after returning from a lengthy trip, I updated both iMatch and iMatch Anywhere (IMA) to the latest versions. I used iMatch to add new folders containing this year's photography and proceeded to curate and catalogue them as I have done in the past. All worked well and as expected.

However, when I tried to use IMA to display some of the recent photos, I found that they were not included in the folder structure or timeline. That is, none of the folders containing 2024 photos were visible in IMA webViewer or on its timeline.

Because my wife and I use IMA in non-read-only mode to collaboratively work on the catalogue, I use the one copy of the database (suitable backup copies exist) in both iMatch and IMA. I've tried restarting both IM and IMA, reboot of the computer and so on several times, but folders I have just worked on in IM remain invisible in IMA.

I don't have a clue where to start resolving this one. Apart from this non-trivial flaw, IMA appears to be working properly. I have attached an IMA logfile.


Make sure you use the same database in IMatch and IMatch Anywhere. That's a common mistake users make, especially when copying databases around. Unless you work with user-specific ACLs, IMA will always show the same folders, categories, collections etc. as IMatch.
-- Mario
IMatch Developer
Forum Administrator  -  Contact & Support - Follow me on 𝕏 - Like on Facebook


Ah, yes, I had forgotten that the other thing that happened in January was that I installed a 1TB SSD for C: drive and copied the database to it for faster access. Of course, I redirected iMatch, but totally forgot to point IMA to the new location.

Mea culpa!