Author Topic: Prevent import of pdf-keywords  (Read 123 times)

sinus

  • Global Moderator
  • *****
  • Posts: 4707
  • IMatch-User since 2001 (IMatch 3.6)
Prevent import of pdf-keywords
« on: June 24, 2022, 05:50:51 PM »
I do also manage pdfs in IMatch, works great.
Now I have hundrets of pdf, created by a finance institute.

And these pdfs creates all some keywords, I do not use them.

Would not be bad, but of course they all appear under the keywords in the categories, which is absolutely unnecessary (and takes up space).

I really don't have any idea right now, is there any way to prevent this import of keywords in pdf?
Best wishes from Switzerland! :-)
Markus

sinus

  • Global Moderator
  • *****
  • Posts: 4707
  • IMatch-User since 2001 (IMatch 3.6)
Re: Prevent import of pdf-keywords
« Reply #1 on: June 24, 2022, 05:51:19 PM »
I do also manage pdfs in IMatch, works great.
Now I have hundrets of pdf, created by a finance institute.

And these pdfs creates all some keywords, I do not use them.

Would not be bad, but of course they all appear under the keywords in the categories, which is absolutely unnecessary (and takes up space).

I really don't have any idea right now, is there any way to prevent this import of keywords from pdfs?
Best wishes from Switzerland! :-)
Markus

Mario

  • IMatch Developer
  • Administrator
  • *****
  • Posts: 31554
Re: Prevent import of pdf-keywords
« Reply #2 on: June 24, 2022, 06:00:29 PM »
Most likely your PDF files have embedded XMP data with keywords.
You can check in the ExifTool Command Processor, for example.

If you don't want these keywords, you can just delete them in the Keywords Panel and write-back?

There are no options in IMatch to exclude XMP keywords for selected file formats, if this is what you are looking for.

sinus

  • Global Moderator
  • *****
  • Posts: 4707
  • IMatch-User since 2001 (IMatch 3.6)
Re: Prevent import of pdf-keywords
« Reply #3 on: June 24, 2022, 06:03:20 PM »
Most likely your PDF files have embedded XMP data with keywords.
You can check in the ExifTool Command Processor, for example.

If you don't want these keywords, you can just delete them in the Keywords Panel and write-back?

There are no options in IMatch to exclude XMP keywords for selected file formats, if this is what you are looking for.

Great answer, thanks, Mario.
I will do exactly, what you have written: delete the keyword-categories in the categorie or in the keyword - panel.

That will do it ... I just was not sure, if there is such a option to exclude XMP keywords.

Fine, problem solved, thanks!  :)
Best wishes from Switzerland! :-)
Markus