[IM2021.14.4] Problem with character on IPTC data

Started by Rene Toepfer, March 06, 2022, 11:13:26 AM

Previous topic - Next topic

Rene Toepfer

Good Morning,

yesterday I've checked-in three TIFF16bit to IM2021.14.4 (64 bit).

These TIFF contain GPS data and I have set several keywords. Afterwards write back these TIFF were presented again with unwritten metadata, so I did another rewrite which resulted in that IM was again of the opinion the metadata are unwritten and so on – captured in an endless loop.

I re-checked if there is metadata template which will be applied afterwards refreshing – but it is not. I also checked the character sets but it is still the default values (see attachement 2022-03-06_10-50-37.png).

Then I have removed all metadata by using the Exiftool command processor (F9,E) and removed these TIFF from IM2021 and restarted IM.

Now I checked these TIFF in again. The metadata template was set properly, GPS data loaded from Google. Everything was fine. Now I did another write back but the problem occurred again. Then I realized that IM replaced "Composite\MWG-City\City\0=Köln" by "Composite\MWG-City\City\0= Köln" – this exchange is the reason for IM that it marks "unwritten metadata".
In the metadata (F9,E) are following entries (see also 2022-03-06_10-50-03.png):
[IPTC]          Keywords                        : Ort, Deutschland, Köln, Stadt met K, Kalk, Region, Rheinland, Personen, Laura Lutgen, Tanz, Ballett
[IPTC]          City                            : Köln

The keywords in the keyword panel are shown correct, see 2022-03-06_10-50-18.png.

Interesting is, it is only for three TIFF, remaining four TIFF are fine and the a.m. behaviour does not occur. All TIFF were created with PS2022 (v23.2.1, 64 bit) on Windows10 Pro.

How can I solve this issue? Maybe it helps to remove the incorrect value "Köln" and rewrite the metadata.

Thanks in advance,


The IPTC data you use has been declared deprecated 20 years ago.
IMatch does not create legacy IIM3 IPTC data, but updates existing legacy IPTC data when it exists.

One of the many, many problems with the old IPTC data was character sets and how they can mess up non-ASCII characters  (like the German ö in your example).
A IPTC record containing country-specific text like Köln would usually show up totally messed up on another computer which did not use the German character set.
Lots of problems with that.

My assumption is that the IPTC record in your file does not use a character set or the wrong character set, thus messing up the encoding.
You can overcome this (with side-effects) using the corresponding options for legacy IPTC data in Edit > Preferences > Metadata. See help for details.
You use UTF8 hard-coded, which may work or not. Be very careful when you hard-code character sets and metadata propagation between XMP and IPTC, especially when your keywords are not synched.

Generally, mixing a 20 year out-of-date metadata format with German umlauts is probably not a good idea.

I have removed legacy IPTC data from all my images 10 years ago. There is a ExifTool Command Processor preset for that.
I don't need it. No client or agency needs it.
And in the rare case is is needed - I usually write keywords and captions in English. If not, I make sure that the legacy IPTC character set is set accordingly to the character set needed for the text data.

I would recommend you consider getting rid of legacy IPTC, especially when it causes character-encoding issues like in your example.
Or just stick to ANSI characters.
XMP is UTF8 so no issues.
-- Mario
IMatch Developer
Forum Administrator
http://www.photools.com  -  Contact & Support - Follow me on 𝕏 - Like photools.com on Facebook

Rene Toepfer

Thanks for your explanation, Mario. Now this issue is solved and I have switched off legacy IPTC for TIF(F) (https://www.photools.com/help/imatch/md_writeback.htm?dl=h-9). Interesting is: For JPG it is set to write legacy IPTC by default but does not.

But where did it come from and why are only a few TIFF affected? It makes no sense to write keywords in some TIFF in legacy IPTC and in others not. The TIFF were created from the scratch in PS and in PS I have not set any metadata (for this IM is my favorite tool). I just want to understand where it came from to prevent such behaviour in the future. But maybe it is not a general issue, otherwise I would have this issue in all other 100k+ files within IM.


IMatch does not create legacy IPTC by default, it only updates existing legacy IPTC. This is common practice. Do not turn this off.
Your TIFF files may just contain the wrong character set encoding or none, which makes ExifTool process the characters wrong.
Either remove the legacy IPTC record or make sure that the character set the originating software writes to your TIFF files matches the actual character set in which the data was created.
If these are old files, remove the legacy IPTC or set the character set manually via the ECP to fix the problem.
-- Mario
IMatch Developer
Forum Administrator
http://www.photools.com  -  Contact & Support - Follow me on 𝕏 - Like photools.com on Facebook