Can't find the Hierarchical Thesauraus - Operator Error

Started by PandDLong, February 25, 2021, 01:56:20 AM

Previous topic - Next topic


 I am just in the process of evaluating iMatch as my DAM.  So far so good.  It is certainly a highly functional and configurable product.

I think the latter is what has caused me a problem.

In my Keyword panel I can't find the Hierarchical Thesaurus.  Looking at the online Help it should be there somewhere.  After the History section I just have some light coloured text "The Thesaurus contains no entries", then black background.  I've expanded the panel as large as possible in case it got pushed down to the bottom but there is nothing there.   (There are a couple of hierarchical keywords in my used list as they were imported).

Did I lose it in the panel config somehow?   Is there a quick way to "reset" a panel to a default.  Or is there some other feature I have to click to get it on-screen?

I apologize for such a beginner question but I have spent 30 minutes trying to figure it out to no avail


The icon for the Thesaurus Manager is in the Metadata Panel.
You have to fill in values to the thesaurus first, to be able to see them in the Keyword panel.

See following help topic.
There is also a very useful search function on the top right corner of the online help.


IMatch by default fills the thesaurus from a standard thesaurus included in the installation. Not sure why this is empty.

You can load the standard thesaurus again via the Thesaurus Manager accessible in the Keyword Panel.
Click on the thesaurus button in the toolbar at the top of the Keyword Panel.
Click on the Import & Export button in the Thesaurus Manager toolbar.

You can now either let IMatch fill the thesaurus from the keywords already in your files, or you can use the "Import Thesaurus..." command and import the default thesaurus from the file


on your computer.

-- Mario
IMatch Developer
Forum Administrator  -  Contact & Support - Follow me on 𝕏 - Like on Facebook


Got it.

Yes, the Thesaurus manager was empty - not sure why either because I do have keywords in my database.

Problem solved - I used the import function and chose "From Database".

All is good now.

Appreciate the quick responses.   

PS.  I never get the verification answer for the 'letters appear twice' question - it is always rejected.  I think I know the answer but I can't find a way to enter it right.   


That there are no keywords in your database does not affect the initial setup of the thesaurus.
When IMatch finds that the thesaurus is empty during the first run (!), it imports the default thesaurus with a very usable controlled vocabulary - as a starting point for new users.
Maybe you've had IMatch installed in the past and the thesaurus already existed?
-- Mario
IMatch Developer
Forum Administrator  -  Contact & Support - Follow me on 𝕏 - Like on Facebook



I appreciate the follow-up.   Given that this behaviour is a little odd - here is a little more context:

1. Definitely the first time I've installed iMatch.  The computer is pretty new and had practically nothing beyond Microsoft Office installed (and it is mine so no-one else loaded it without my knowledge).

2. I don't recall being presented an option to import a thesaurus - but perhaps there was and I declined?    (having installed 7 products in the last month some of the details are fuzzy).

3. I did manually add some keywords to some of my test photos just as a rudimentary "how does iMatch work?" activity.  These keywords were in my "recent" list - including a couple hierarchical ones.

4. It is when I chose to dig more deeply into iMatch keywording capabilities that I noted the thesaurus being empty - and my initial note on this forum.

5. Perhaps I accidentally emptied/deleted it - without realizing it.

I provide the above info not to complain nor to have you explain why/how it happened.  It is just for your information in case it is useful as the developer.



Very strange.
The thesaurus is automatically imported when a new database is created. This happens automatically, before you see the "Database successfully created" dialog where you can set some initial options.
When you create a another database via Database menu > New, then add some files, select one so the Keyword Panel shows data, is the thesaurus empty again?
In that case, the IMatch log file (log file) should contain an error message or warning about the reason for this.
-- Mario
IMatch Developer
Forum Administrator  -  Contact & Support - Follow me on 𝕏 - Like on Facebook


I ran through a couple tests as you suggested.

1.  New database, add some files, selected a file with a pre-existing keyword - and the thesaurus was populated with a default.

2. Created another new database and added files that had no pre-existing keywords - and ...  the thesaurus was populated with the default.

I also noticed that I was never given an option to say "no" to the initial thesaurus import.   

So I have no idea why mine was blank as per the start of this post.

A mystery that may remain unsolved!


It's back!  Or should I say it's gone!

I just purchased and installed a licensed version.  I opened up one of the test databases (which was created as per prior post) and the thesaurus was empty.  This time I took a picture of the situation in case that helps (file attached).

I reimported the default thesaurus, closed and reopened the database and it is seeming to stick.