Error setting GPS coordinates

Started by asbr, October 05, 2020, 06:19:25 PM

Previous topic - Next topic


I seem to have the same problem as dadu ( but the solution he has suggested does not seem to work for me. When I try to set the location of a photo using the map panel I get the error message:
Error setting GPS coordinates
A problem occurred while setting or updating the GPS coordinates for one or more files.
  "error": {
    "code": 1100,
    "message": "Internal error.",
    "details": {
      "result": "failed",
      "errorInfo": "Failed to reverse geo-code the files: \"\"."

I have done what dadu suggested, namely enabled Geocoding API, Maps Elevation API, Maps Javascript API. I have checked that these are enabled on the Google Cloud platform. The map that is displayed in the Imatch maps panel is a Google street map, showing, I think, that I have successfully enabled Google mapping.

I don't have much understanding of all this; I am working near the edge of my knowledge. I feel certain I am making a simple error that will be obvious to others and I am hoping someone will tell me what to do to get this working.

Thank you


The map provider you use for the Map panel and which service you use for reverse geo-coding and searching can be different.
Check under Edit > Preferences > Geo & Maps that you have configured Google for reverse geo-coding, not or HERE.

I have just verified that Google, HERE and all work for reverse geo-coding so it should work for you as well.
Always include the full (zipped log file), because it will contain additional information about the problem, e.g. the Google error message. This will help to figure this out.

Tip: Do you have added a payment method to your Google account?
Even when you don't use up your monthly free quota, Google requires a payment method (credit card) since June 2019.
-- Mario
IMatch Developer
Forum Administrator  -  Contact & Support - Follow me on 𝕏 - Like on Facebook


Thank you. My mistake was to put for reverse geo-coding. I have changed it to Google and it now seems to be working.