Author Topic: ExifToll and Imatch R/W metadata  (Read 1116 times)

Jean-Maetso

  • New Members
  • *
  • Posts: 26
ExifToll and Imatch R/W metadata
« on: April 25, 2020, 09:59:30 AM »
Hello community,

I am exploring Canon metadata in my pictures: Canon/Quality. This metadata {File.MD::Canon\CameraSettings\3\Quality\0} contains  an integer which, when formatted, describe the quality of the JPG picture: Normal, Fine, SuperFine...

When using the Imatch metadata variable as above, I can see the Metadata (with or without "value:formatted" option) and use it in layouts, File window, etc.

Having updated and writing-back another metadata in the file (for instance XMP::dc/Title, never mind), the Canon metadata seems to have disappeared. The evaluation of {File.MD::Canon\CameraSettings\3\Quality\0} is now empty. With or without formatting.

When I use the Metadata panel (having configured it to display the appropriate fields) to re-enter the value "Fin" in Image/Quality, the "yellow pen" icon appears near my picture. And the value "Fine" appears in the Window layout (that I have configured to display the {File.MD...} variable. I take this as a proof that IMatch Metabase correctly include the value "Fine" for the "Quality" tag.

But as soon as I click on the yellow pen icon, the metadata seems to vanish. The Window Layout does not display the value anymore, exactly as if the metadata has been deleted in the file (and in the metabase).

When running ExifTool with option -Canon:Quality, I can immediately check that the metadata is indeed present in the file.

Why IMatch  does no longer show me the metadata which is actually (for sure) in the file?...
Does anybody have ever encountered the same problem?

The problem is not specific to a file, I have tested and reproduced it with many files, old ones, new ones, duplicates ones.
The problem is not specific to the Tag, I can reproduce it with CanonImageSize, Canon\EasyMode, Canon\FocusMode, CanonMacroMode... (yes, I own a Canon camera... :-))

I know that Camera Makers are a source of nightmare and durty things with metadata. But I have the opposite impression regarding Imatch, and thus am a bit disappointed with this "apparent" mismatch between IM and Exiftool.

Thanks for any explanation,
JM

Mario

  • IMatch Developer
  • Administrator
  • *****
  • Posts: 31552
Re: ExifToll and Imatch R/W metadata
« Reply #1 on: April 25, 2020, 11:14:05 AM »
1. When you switch the MD Panel into browser mode, you see all metadata imported by IMatch.
2. The ExifTool Command Processor allows you to see all metadata in the file. Check a file before and after write-back to see if and what ExifTool has changed.
3. IMatch does not import many of the maker notes not intended for humans. These tags may be part of the data IMatch skips to not fill the database with unnecessary data.
See The Tag Manager for more info.

Jean-Maetso

  • New Members
  • *
  • Posts: 26
Re: ExifToll and Imatch R/W metadata
« Reply #2 on: April 25, 2020, 01:24:38 PM »
Yep! Problem is solved. But I need a clarification, see below.

1. Yes, when I switch MD Panel in browser mode, I see metadata imported by IM. Editing and writing back the Tag through the MD panel leads to my problem (value is 'disappearing' from the panel just after I click on the yellow pen icon in the file window)

2. Yes, I had used ExifTool before and after. The value is embedded in the file, before and after.

3. Yes, I had also configured the Tag manager (actually I did not need to change anything in the default configuration).
--> But when checking it just now, the Group 'CanonCameraSettings' is unchecked.
--> However, I am pretty sure that I checked it, intentionally...
--> I am very surprised to see it unchecked. But I am very happy, rechecking this group has solved my trouble.

MANY THANKS MARIO!

Thus my final question: when I was looking for the reason of my problem, I had used the IM Backup package 'impag' generated from Pack&Go. This allowed me to get the database in a previous state, re-open it read-only, test what was visible and so on.
Maybe the changes in the tag manager come from here : I reload one previous version of my database with another set of tags to be imported by Imatch.
Could you tell me what exactly is embedded in the Pack&Go backup? The settings of metadata import is considered as DB-wise, Application-wise, user-wise.. ? Is it overridden when I re-load a backup, having made changes in the meantime?

Best,
JM

Mario

  • IMatch Developer
  • Administrator
  • *****
  • Posts: 31552
Re: ExifToll and Imatch R/W metadata
« Reply #3 on: April 25, 2020, 01:50:20 PM »
Pack & Go backups all settings and optional databases.
Metadata Settings are stored inside the database.

Jean-Maetso

  • New Members
  • *
  • Posts: 26
Re: ExifToll and Imatch R/W metadata
« Reply #4 on: April 25, 2020, 03:05:01 PM »
Thanks again for all support and explanation... as always !! and have a nice week-end, take care !