Author Topic: Redundancy of keywords under “@keywords” and in the Keywords panel  (Read 99 times)

emef

  • Full Member
  • **
  • Posts: 137
Good morning all,
in the "Categories" tab. I only use “@keywords” to add. subtract or modify the keywords. So I have the categories "Who", "Where" and "What" directly under "@keywords" (colored labels).

What bothers me is that IMatch recreates the keywords for me under these three categories and I find it a bit messy on the screen (see Categories@keyword.JPG).
I did try, in the “Files Categories” panel, to uncheck the redundant keyword “Cathedral” for example (see Categories@keyword_2.JPG) but periodically it reappears.
Is there any way to eliminate these extra non-colored "@keywords"; or give them a hierarchical classification like I did for my colorful “@keywords”.

Sorry to have been a little long, but I hope I made myself clear  :-\

Thank you in advance.

Mario

  • IMatch Developer
  • Administrator
  • *****
  • Posts: 24491
IMatch does not split hierarchical keywords or duplicate them.
Maybe this is caused by your thesaurus? Or synonyms?

If this happens after write-back, check the settings you use for flatting hierarchical keywords under Edit > Preferences > Metadata.
Also look at the actual keywords in your image using the ExifTool Command Processor and the "All Keywords" preset. This shows you the hierarchical keywords in your files and also the flattened keywords in XMP and legacy IPTC.

If your flatten keywords cannot be mapped back to hierarchical keywords during import via your thesaurus, they will end up 'as-is' and thus show in multiple places in @Keywords. This is often expected, actually. Depending on your workflow.

emef

  • Full Member
  • **
  • Posts: 137
Thank you for your prompt response.
I checked with the ExifTool Command Processor and the "All Keywords" preset: There are indeed the keywords that motivated my question in the IPTC field. This could come from the “IPTC” and “XMP-lr” fields. The only field that seems correct is “XMP – dc”.
Can I, and how, delete “IPTC” and “XMP-lr”?
Or did I not understand what you are trying to tell me  ::)

Mario

  • IMatch Developer
  • Administrator
  • *****
  • Posts: 24491
You cannot delete these tags.
IMatch creates them (and has to) during write-back from hierarchical keywords.
Hierarchical keywords are very elegant and powerful - but they are not part of either the XMP or IPTC standard. They are an extension.
IPTC and XMP only knows flat keywords like "beach" or "Volvo".

These tags contain flattened variants of your keywords. You can control if you want to write the complete hierarchical path, all levels of the path or only the leaf levels.
This is all explained in the help. Did you read it?

Write hierarchical keywords

If you have created a combination of keywords, thesaurus and options that causes this, only you can fix it.
Make sure you understand what IMatch actually has to write into your files, how IMatch maps flat keywords found in your images back into hierarchical keywords using your thesaurus etc.

All this is explained in the help topic I linked to above.

emef

  • Full Member
  • **
  • Posts: 137
Thank you. I read the help regularly before asking a question, but my level of English leaves something to be desired and the translation by Google or others is sometimes tendentious.
But as we say: “A hundred times on the job ...”

I thought that by unchecking in the “File Categories” panel the boxes opposite my non-colored “@keywords” keywords and keeping only my colored @keywords and then clicking on the pencil it would solve the problem, but it does not seem not be the case. If they sometimes disappear in the “Categories” tab, a refresh of the database causes them to reappear.
It becomes exhausting, but bast, I will plunge again into the help.

Mario

  • IMatch Developer
  • Administrator
  • *****
  • Posts: 24491
The main feature for working with keywords is the Keywords Panel. Here you can see the thesaurus, the hierarchical keywords as they are added to your file, synonyms if you have used them etc.

After write back, check the flat keywords in your file.
If they cannot be mapped back via your thesaurus to hierarchical keywords, duplicates on different levels may appear.

LOCATION|beach|Daytona

may be flatted (depending on your options) to

A) Daytona
B) LOCATION, beach, Daytona
C) LOCATION|beach|Daytona

If you let IMatch produce A) or B) and there is no way to map, for example, "Daytona" back into "Location|beach|Daytona" via your thesaurus, IMatch will add the flat keyword "Daytona" during import.