Author Topic: Upgrading from IMatch 5  (Read 219 times)

ilan

  • Jr. Member
  • *
  • Posts: 71
Upgrading from IMatch 5
« on: October 12, 2019, 01:37:52 PM »
I am still using IMatch 5.4.18. Does upgrading to the current IMatch 2019 version require any special procedure? Can I leave IMatch 5 installed after installing IMatch 2019?

Jingo

  • Super Hero
  • ****
  • Posts: 1164
Re: Upgrading from IMatch 5
« Reply #1 on: October 12, 2019, 02:04:52 PM »
Though old.. this page provides some info:  https://www.photools.com/imatch-2019-for-imatch-5-users

You'll want to backup your database because once you updated, your old version will no longer be able to access the database once converted.  You should be able to run both versions side-by-side... note, there are some major differences between IM5 and IM2019 so reading the online help and getting started guides will be quite helpful.  If you use scripts, please note they will no longer work in 2019 as visual basic has been replaced by the more robust Javascript language...

Enjoy! - Andy.

ilan

  • Jr. Member
  • *
  • Posts: 71
Re: Upgrading from IMatch 5
« Reply #2 on: October 13, 2019, 03:34:21 PM »
Thanks for the answer. Is there a way to import the old IMatch 5 database to the trial version of IMatch 2019? It would be nice to test run IMatch 2019 with real data. I installed the trial version 2019.8.3 and I get the following error message:

Database Upgrade Required.

This database was created by an older IMatch version and needs to be updated in order to work with the current version.

IMatch cannot do this when the database is opened in READ-ONLY mode. Please open the database in writable mode or ask your Administrator.

NOTE: The Trial version of IMatch opens databases older than 30 days always in read-only mode, it cannot be used to upgrade old databases. You can create a new database for testing purposes.



Jingo

  • Super Hero
  • ****
  • Posts: 1164
Re: Upgrading from IMatch 5
« Reply #3 on: October 13, 2019, 05:14:38 PM »
as you discovered, you can only use the older database in read only mode until you purchase a license to the full version... but - you can always make a copy of your database and open that with the new version to see how all your categories and other "database only" items look in the new release.  Then, you can create a new database and import a sample group of images to perform your workflow in the new version.

IM2019 has a TON of new features that really are great... moving from IM5 to 2019 is a great choice in my opinion and worth the upgrade.  Good luck!

Mario

  • IMatch Developer
  • Administrator
  • *****
  • Posts: 23018
Re: Upgrading from IMatch 5
« Reply #4 on: October 13, 2019, 06:30:56 PM »
No support is available anymore for IMatch 5.

The trial version cannot convert old databases.
It opens all databases older than 30-days in read-only mode.

You cannot open a database created with an old licensed version of IMatch in a current trial version.
The trial version is intended to allow new users to try out IMatch on their PC.
It was not designed for users with a version several generations out of date to, I presume, re-evaluate IMatch with their existing database after a couple of years.

If you are really unsure if you should upgrade your legacy version of IMatch, I suggest you just create a new database in IMatch 2019 and try out all the new features.
Then buy the new version, install it and upgrade your legacy database to a current version of IMatch.

Note that, since your version is several generations of of date, there is no upgrade discount available for you anymore.
I only provide discounts for upgrades between major versions.

For all the changes you have missed, see the extensive documentation on my web site:

IMatch 2019 for IMatch 5 Users: https://www.photools.com/imatch-2019-for-imatch-5-users/

https://www.photools.com/imatch-2018-whats-new/
https://www.photools.com/imatch-2019-whats-new/

ilan

  • Jr. Member
  • *
  • Posts: 71
Re: Upgrading from IMatch 5
« Reply #5 on: October 13, 2019, 07:14:12 PM »
Thanks for the info. I understand there is no discount any more. I just wanted to make sure the licensed IMatch 2019 installation will "understand" my old database.

Mario

  • IMatch Developer
  • Administrator
  • *****
  • Posts: 23018
Re: Upgrading from IMatch 5
« Reply #6 on: October 13, 2019, 07:25:34 PM »
I just wanted to make sure the licensed IMatch 2019 installation will "understand" my old database.

The format is compatible. In all the years since version 5 I don't recall any compatibility problem.

Of course its always a potential risk to let your software become out-of-date for so many years.
I cannot control the technology and I cannot test each and every IMatch version ever released for compatibility with versions released several years after.
I test and ensure compatibility between major versions: IMatch 5 => 5.5 => 2017 => 2018 => 2019.

Belenos2017

  • New Members
  • *
  • Posts: 23
Re: Upgrading from IMatch 5
« Reply #7 on: October 13, 2019, 10:34:42 PM »
Hi Ilan,
I hesitated a long time, so I upgradet only 2 years ago from Imatch3.5 to Imatch 5 and later to Imatch 2019. And the Result: It is absolutely worth!! Every day I use Imatch 2019 I am absolutly happy, I am amazed about Marios great Work!!

So: Do it !

Aubrey

  • Super Hero
  • ****
  • Posts: 1043
  • IMatch user since June 2008
Re: Upgrading from IMatch 5
« Reply #8 on: October 14, 2019, 09:02:25 PM »
And IMatch 2020 is just around the corner!
(I expect)

Aubrey.

ilan

  • Jr. Member
  • *
  • Posts: 71
Re: Upgrading from IMatch 5
« Reply #9 on: October 19, 2019, 07:49:26 AM »
Thanks everyone. I did the upgrade a few days ago and IMatch 2019 opened the old database without any problem.