Author Topic: Geosetter configuration after Google Maps API changes  (Read 351 times)

jch2103

  • Super Hero
  • ****
  • Posts: 1602
Geosetter configuration after Google Maps API changes
« on: January 07, 2019, 01:20:15 AM »
Friedemann Schmidt has posted instructions on how to use GeoSetter with Google Maps following changes to their API. If you have a Google Maps API key, you can use it in Geosetter with this information:

http://www.geosetter.de/mantis/file_download.php?file_id=739&type=bug

I can confirm that it works. Normally, I'd just use IMatch but Geosetter is useful for dealing with fixing some problem files that have incorrect GPS coordinates.
John

Carlo Didier

  • Super Hero
  • ****
  • Posts: 1191
Re: Geosetter configuration after Google Maps API changes
« Reply #1 on: January 08, 2019, 09:39:05 PM »
Excellent! Thanks for the tip.

There's just one typo in your doc. Instead of "file:///..." it should be "file://...", only two "/", not three.

PaulS

  • Jr. Member
  • *
  • Posts: 68
Re: Geosetter configuration after Google Maps API changes
« Reply #2 on: January 12, 2019, 06:27:05 PM »
Very cool!  Thanks John.

Mario

  • IMatch Developer
  • Administrator
  • *****
  • Posts: 21488
Re: Geosetter configuration after Google Maps API changes
« Reply #3 on: January 12, 2019, 07:07:21 PM »
Quote
I can confirm that it works. Normally, I'd just use IMatch but Geosetter is useful for dealing with fixing some problem files that have incorrect GPS coordinates.

Anything that's useful for more than a few users and maybe should be added to the IMatch Map Panel?

jch2103

  • Super Hero
  • ****
  • Posts: 1602
Re: Geosetter configuration after Google Maps API changes
« Reply #4 on: January 12, 2019, 11:46:27 PM »
Quote
I can confirm that it works. Normally, I'd just use IMatch but Geosetter is useful for dealing with fixing some problem files that have incorrect GPS coordinates.

Anything that's useful for more than a few users and maybe should be added to the IMatch Map Panel?

Yes.

#1. The 'Ignore files with existing GPS data' checkmark doesn't seem to do anything currently (see https://www.photools.com/community/index.php?topic=8692.0).

#2. I was working with images taken during a 14 hour day, with the latest version of Nikon's SnapBridge and my Nikon Z6. Some images were tagged with inaccurate GPS coordinates, but I had also recorded a GPX track using my Garmin 935 watch which proved much more accurate. (See https://www.dpreview.com/forums/post/62161884 for details).

I had two issues with the IMatch Map Panel for the GPX track; the first issue related to #1 above, the other with locating my images within the long GPX track (that is, the images were within only a portion of the track) and applying the proper time zone offset. In my prior use of the Map Panel, I hadn't run into issues, mostly because the images hadn't had existing coordinates. In this case, the combination of #1 above and the long GPX track relative to the time interval during which images were taken made it difficult to try to set the proper offset.

The Help refers to the screenshot of the Time Zone Offset window, "1 The timeline gathered from all images in the current scope (selected files in the active File Window)." However, it actually seems to include all files in the current active File Window, irrespective of whether they are selected or not (is this bug #2?). In my situation, the File Window included images from days before and after the images I was working with, so the Settings window showed the images spanned 296.90 hours(!).  See screenshot.

To further complicate things for me, the TZ Offset window File Timeline referred to Local time (i.e., -7:00 UTC on my home desktop) rather than the time zone where the images were taken (-10:00 UTC), and because of bug #1 showed 0 of 0 files mapped.

I then turned to GeoSetter and was able to geocode all of the images after using a -10 hour offset between images and my 0:00 UTC GPX track.
« Last Edit: January 12, 2019, 11:53:23 PM by jch2103 »
John

Mario

  • IMatch Developer
  • Administrator
  • *****
  • Posts: 21488
Re: Geosetter configuration after Google Maps API changes
« Reply #5 on: January 13, 2019, 09:32:07 AM »
I will look into your #1 issue for one of the next releases. Thus bug report is still open but I'm working on other important things right now and it might take a bit until I get there.

If you found a bug, please add a bug report. If you want a feature enhancement, please post it in the FR board.
This "Off Topic" board is not the right place and I will not remember in a month.

Quote
To further complicate things for me, the TZ Offset window File Timeline referred to Local time

A track log covering 300 (!) hours is a bit unusual.
The purpose of this offset is to match the time recorded in the track log with the time recorded in the EXIF record of your images.
Basically, how many hours and minutes to add/remove to/from the image time time to fit it to the track log.
Track logs (supposedly) record time always in UTC. This is the base on which the Map Panel has to operate.
Timestamps in EXIF are usually in local time (whatever is set in the camera).

The track log offset displays UTC time and the matching local time, as a hint.

« Last Edit: January 13, 2019, 10:02:43 AM by Mario »

jch2103

  • Super Hero
  • ****
  • Posts: 1602
Re: Geosetter configuration after Google Maps API changes
« Reply #6 on: January 13, 2019, 07:29:40 PM »
A track log covering 300 (!) hours is a bit unusual.

No, the track log was only ~11 hours. The 300 hours was the time span for the image files in that folder.
John

Mario

  • IMatch Developer
  • Administrator
  • *****
  • Posts: 21488
Re: Geosetter configuration after Google Maps API changes
« Reply #7 on: January 13, 2019, 07:35:39 PM »
Right. My bad.