Author Topic: Viewer overlays cropped or not displayed at all  (Read 426 times)

lbo

  • Full Member
  • **
  • Posts: 156
Viewer overlays cropped or not displayed at all
« on: September 30, 2018, 02:43:34 PM »
Hi all,

overlays in the viewer are cropped to the image extents. IOW if my image is not as large as my screen, overlays are displayed only partially (if any).

See (size reduced) screenshot: Only half of the text overlay and a tiny fraction of the dashboard is visible.

Overlays vanish completely after zooming in with Ctrl-mouse wheel to certain size. I have to zoom to a smaller size, exit the viewer and invoke the viewer again to view the overlays again.

Strange error...

Running 2018.8.7 on W7

Oliver

Mario

  • IMatch Developer
  • Administrator
  • *****
  • Posts: 21489
Re: Viewer overlays cropped or not displayed at all
« Reply #1 on: September 30, 2018, 02:46:09 PM »
Do you use an Intel graphic card in a Notebook perhaps?
The clipping on the image borders is a known issue with certain Intel graphic cards / drivers. No solution is available, unfortunately.
The card / driver just clips the overlays on the image border. When you zoom in and the image fills the entire screen, usually all overlays are visible. This only happens on consumer Intel CPUs, mostly in Notebooks.

lbo

  • Full Member
  • **
  • Posts: 156
Re: Viewer overlays cropped or not displayed at all
« Reply #2 on: September 30, 2018, 03:09:23 PM »
Thanks for the quick reply, Mario!

Do you use an Intel graphic card in a Notebook perhaps?

exactly, a Lenovo notebook with Intel HD Graphics 520. Let me know it I can help to investigate the problem.

As you write, the overlay become visible if I zoom in with Ctrl-Numkey.

But if I zoom in with Ctrl-Mouse, they fade out completely and do not reappear unless I re-invoke the viewer with a smaller zoom factor.

This means, even if I exit and re-invoke the viewer with the zoom factor causing the overlays to disappear, the overlays are not back.

Likely a different problem.

Oliver

Mario

  • IMatch Developer
  • Administrator
  • *****
  • Posts: 21489
Re: Viewer overlays cropped or not displayed at all
« Reply #3 on: September 30, 2018, 04:00:50 PM »
This would be a new effect. The overlays are supposed to fade out while you zoom/pan but they should fade in back afterwards.

This bug is a reappearance of a bug Intel apparently had solved years ago. IMatch uses DirectX as intended and designed. It's only ever on Intel graphic cards (neither AMD or nVidea show this problem) that this clipping occurs. If you have a nVidea card in that system as well, switch it so IMatch uses that card instead of the Intel card. This solves the problem. If you have only the Intel card, I'm unfortunately unable to help. I have tried what's possible years ago, when this problem showed up the first time.

Mario

  • IMatch Developer
  • Administrator
  • *****
  • Posts: 21489
Re: Viewer overlays cropped or not displayed at all
« Reply #4 on: January 01, 2019, 08:26:22 PM »
Does this still happen with IMatch 2019?
I've made some changes "into the blue" (no Intel graphic card available, except in my Windows 10 tablet and there it works - and worked before).

ben

  • Sr. Member
  • **
  • Posts: 398
Re: Viewer overlays cropped or not displayed at all
« Reply #5 on: January 02, 2019, 01:36:02 PM »
Quote
Does this still happen with IMatch 2019?
I've made some changes "into the blue" (no Intel graphic card available, except in my Windows 10 tablet and there it works - and worked before).
Unfortunately the issue still exists, but it's not a problem to me. I simply use my dedicated graphics in the laptop.

Intel HD Graphics 520 --> clipping occurs
Geforce 945M --> no clipping

See the screenshots made in the viewer with the same picture

iMatch 2019.1.2

Ben



lbo

  • Full Member
  • **
  • Posts: 156
Re: Viewer overlays cropped or not displayed at all
« Reply #6 on: January 03, 2019, 06:59:45 PM »
Hi Mario,

first of all I wish you a happy new year.

Thanks for the many improvements and fixes in the new IMatch version!

Does this still happen with IMatch 2019?
I've made some changes "into the blue" (no Intel graphic card available, except in my Windows 10 tablet and there it works - and worked before).

sadly no change, the overlays are clipped at the image boundaries.

Like Ben, I'm currently using Intel UHD 520 graphics in a Lenovo Thinkpad.

Ben, "Geforce 945M" means you don't use a Lenovo laptop like me? So we may exclude that Lenovo messed up something?

My next portable will be much faster but still use Intel UHD Graphics 620, not that different from UHD 520. We'll see whether this makes a difference.

ben

  • Sr. Member
  • **
  • Posts: 398
Re: Viewer overlays cropped or not displayed at all
« Reply #7 on: January 04, 2019, 10:08:28 AM »
Quote
Ben, "Geforce 945M" means you don't use a Lenovo laptop like me?
Yes, I use an Acer laptop. It has two graphic cards. The Intel one as default and the geforce which I configured to be used for iMatch.
So usually iMatch runs on the geforce.
But I understand, if you only have the Intel card than unfortunately you are stuck.

lbo

  • Full Member
  • **
  • Posts: 156
Re: Viewer overlays cropped or not displayed at all
« Reply #8 on: January 04, 2019, 10:43:56 AM »
Thanks for the information.

I just wanted to know whether it is a Lenovo or an Intel issue.

lbo

  • Full Member
  • **
  • Posts: 156
Re: Viewer overlays cropped or not displayed at all
« Reply #9 on: January 13, 2019, 08:58:04 AM »
yesterday I was able to try the IMatch demo on a Lenovo E580 with Intel UHD Graphics 620 (and Windows 10): On this computer the panels were shown as intended.

So it might be an  Intel UHD Graphics 520 issue or a Windows 7 issue or a combination of both.

Ben, which OS do you use?

And I observed that on my (UHD Graphics 520) Laptop, the panel protrudes a few pixels beyond the image area, but only in certain zoom levels. Screenshot attached.

Oliver

Mario

  • IMatch Developer
  • Administrator
  • *****
  • Posts: 21489
Re: Viewer overlays cropped or not displayed at all
« Reply #10 on: March 12, 2019, 09:42:25 AM »
I have decided to implement a work-around for this Intel glitch.

You can now enable an Intel Quirks mode under Edit > Preferences > Application. Search for quirk to find it.
If this option is enabled, the Viewer moves the overlays (Histogram, Collections, Dashboard, ...) inside the area covered by the image. This prevents the involuntary clipping we see on some Intel graphic cards.

lbo

  • Full Member
  • **
  • Posts: 156
Re: Viewer overlays cropped or not displayed at all
« Reply #11 on: March 20, 2019, 06:10:46 PM »
thanks, Mario.

In the mean, I got a powerful desktop PC and plan to start using IMatch productively really soon now.

The Intel Graphics 520 notebook might still be used for remote work.

Oliver