Author Topic: Keywording entry not working  (Read 669 times)

PhotoPhil

  • New Members
  • *
  • Posts: 11
Keywording entry not working
« on: March 12, 2018, 10:07:25 AM »
Hi
My very first question.  I am using Version 2017.14.2 64bit.
I cannot get the Keywording panel entry to work.  When I enter a new keyword or select from the keyword list or the Recent keywords and then click the green tick or press enter, the keyword that I typed or selected just disappears.
The reason must be very simple - any suggestions?
Thanks
Phil

Mario

  • IMatch Developer
  • Administrator
  • *****
  • Posts: 22794
Re: Keywording entry not working
« Reply #1 on: March 12, 2018, 10:36:43 AM »
You are using the Keyword Panel to add your keywords?

PhotoPhil

  • New Members
  • *
  • Posts: 11
Re: Keywording entry not working
« Reply #2 on: March 12, 2018, 10:57:57 AM »
Yes, Mario.
See attached.
I entered "steam" but cannot enter any others, or select from the list and attach them.

Mario

  • IMatch Developer
  • Administrator
  • *****
  • Posts: 22794
Re: Keywording entry not working
« Reply #3 on: March 12, 2018, 11:27:26 AM »
Strange. I also see no metadata in the file window. This looks like something is really messed up.
Did you just try to reboot your computer once?

Please also switch IMatch to debug logging under Help menu > Support.
Then reboot and restart IMatch. Run a database diagnosis from the Database menu > Tools.
Then ZIP and attach the log file.

PhotoPhil

  • New Members
  • *
  • Posts: 11
Re: Keywording entry not working
« Reply #4 on: March 12, 2018, 01:06:00 PM »
There was not any metadata shown in the file Window because I was using the "Titles, Descriptions and Keywords views (and I do not have any titles or descriptions).
I had restarted the PC a couple of times and that did not solve my problem.  I have run the diagnosis and produced the log file but I do not want to waste any more of your time.  It all looks so simple and of course it must be my local problem and not a system problem so I will continue checking and investigating for a while. Thanks....Phil

Mario

  • IMatch Developer
  • Administrator
  • *****
  • Posts: 22794
Re: Keywording entry not working
« Reply #5 on: March 12, 2018, 01:24:48 PM »
This should just work and not cause any problems to you at all.
There is nothing a user could do wrong (as far as I can think at this time). When you enter keywords and commit then, IMatch stores them in the database. And then in the image itself when you write-back the data by clicking the pen icon.

Hence my request for the IMatch log file (Help > Support > View Application log file). In this log, IMatch records problems and errors and this may give us a hint about why this fails on your system. At least at this time I don't recall a similar case.

Can you set rating/label for your files in the file window?
Or add/edit metadata in the Metadata Panel?
Is the database perhaps opened in read-only mode (this shows in the status bar at the bottom, on the right).



PhotoPhil

  • New Members
  • *
  • Posts: 11
Re: Keywording entry not working
« Reply #6 on: March 13, 2018, 03:54:39 AM »
Thanks for replying, Mario.
Yes, I could add labels,ratings and metadata via the panel.

I had been trying to use keywords from the thesaurus and they would not enter.  Then I found that I could enter new keywords that were not in the Thesaurus and realised that my problem was with the Thesaurus.  I noticed that all the keywords imported from my files in the database had square brackets but those few new keywords I had entered did not.  Ah, so after much checking of the help files, I found reference to "Group Level" keywords and that is what all my keywords apparently were.  I deleted the Thesaurus and re-imported the keywords from the database. I no longer have Group Level brackets and the Keyword Panel entry now seems to work as expected. 

I'm not sure how it all happened but there is so much I need to learn.  The explanation above is just for information and as closure for my enquiry.
Thanks so much for your quick response and for you software that I am enjoying very much.
Phil Ryan...Melbourne, Australia

Mario

  • IMatch Developer
  • Administrator
  • *****
  • Posts: 22794
Re: Keywording entry not working
« Reply #7 on: March 13, 2018, 08:12:52 AM »
Aah. I did not look at your initial screen shot long enough, I apologize. I should have seen this.
Indeed, all keywords in this thesaurus are group-level keywords. Hence they are not added to the file, they are just for organizing your thesaurus better.

How did you create this thesaurus? IMatch by default loads the "Universal Thesaurus" it ships with. If this did not work for some reason, you can import it via the Thesaurus Manager from this file:

"C:\ProgramData\photools.com\IMatch6\Presets\system-en.imths"

I include this thesaurus so new users can immediately see how the thesaurus works and have something to build upon.
You can also import other thesauri and keyword lists, or create your thesaurus from the keywords already in your files/database.

VJBasil

  • New Members
  • *
  • Posts: 3
Re: Keywording entry not working
« Reply #8 on: September 11, 2019, 02:56:38 PM »
Hello I have just started to use imatch, after wanting to get rid of lightroom which i only bought for the database function; for the rest I dislike lightroom; for photo work I use several other programs.
I think iMatch is fantastic in every respect, so I decided to buy it. It imported my lightroom database rather well( took only some hours ...)

Anyway for me keywords are the main reason to use this program, but now I stumbled on the same problem described here. I type keywords, they do not appear in the box, sometimes new keywords come through, but I think not always.
I have most if not all keywords from lightroom ok.

I read here that the problem might be the thesaurus. And that I have to delete it. But how would I do that and will my keywords still be ok?

I did nothing special, the thesaurus is from imatch installation.

I hope you can help me to fix this
grtz, Bas Beima

Mario

  • IMatch Developer
  • Administrator
  • *****
  • Posts: 22794
Re: Keywording entry not working
« Reply #9 on: September 11, 2019, 03:58:00 PM »
Hi, welcome to the community.

Where do you type in keywords? In the IMatch Keywords Panel?
What do you mean with "come through"? When you type in keywords in the Keyword Panel editor, you have to press <Return>. Then they show up in the upper list. When you commit your changes, the keywords are saved to the database.

The universal thesaurus in IMatch allows you to create controlled vocabularies of keywords, and then pick keywords from that list. Keywords marked as group keywords in the thesaurus are not added as keywords. You may want to check that. Group-level keywords use a special icon:



See the corresponding videos in the IMatch Learning Center for more information.
« Last Edit: September 11, 2019, 04:01:27 PM by Mario »

VJBasil

  • New Members
  • *
  • Posts: 3
Re: Keywording entry not working
« Reply #10 on: September 12, 2019, 12:44:45 AM »
Yes I do it exactly as shown in the video tutorial, and the problem is exactly like described in the posts above. I do press return and they do NOT show up in the upper list and they are NOT stored to the database.

( only totally new keywords do show up (sometimes) in the upper list....

The keywords that I enter do NOT appear in the upper list where they should appear, neither do keywords in the recent or top 50 list that I click appear in thatupper list, although the oke sign changes to green, but when clicking the ok sign nothing appears in the box....

So what can I do to solve this?


Mario

  • IMatch Developer
  • Administrator
  • *****
  • Posts: 22794
Re: Keywording entry not working
« Reply #11 on: September 12, 2019, 08:36:24 AM »
Then I guess it's the thesaurus you have created.
Did you check for group levels and exclusions?

1. Open the thesaurus manager and export your thesaurus to a file.
2. Switch to the Keywords entry (to see all keywords) and click the topmost entry. Press <Del> to delete all keywords from your thesaurus.
3. Close the dialog with OK.

Then retry entering keywords. If it works now, we know its your thesaurus.
In this case, ZIP and attach your thesaurus. Else, restore your thesaurus by re-importing the file created in step 1.

Also, please attach a log file in debug mode (Help menu > Support > Debug Logging) so we can see if there are any problems reported.
See log file for more info.

VJBasil

  • New Members
  • *
  • Posts: 3
Re: Keywording entry not working
« Reply #12 on: September 12, 2019, 10:36:17 PM »
Hello
Thx for your reply.
I am not aware of creating a thesaurus, it was created by Imatch I think...

Anyway I did what you suggested an it seems to work.
In fact I have to study the concept of thesaurus to understand it; I will do with the keywords for now.

I hereby send the attachements: thesaurus zipped and an log.txt, although I do not know if this is the debug log; when I clicked that nothing happened...

Mario

  • IMatch Developer
  • Administrator
  • *****
  • Posts: 22794
Re: Keywording entry not working
« Reply #13 on: September 13, 2019, 09:09:10 AM »
Most of the keywords in your thesaurus are one the top-level and marked as group levels.
This is most likely not what you ever want to do. Group levels cause keywords to be excluded and this explains the effects you see.

I mentioned that in my first post and also included screen shot in my other post so you can easily identify this situation.
Solution: Remove the group-level option from your keywords in the thesaurus.

Did you import this thesaurus from another software? If so, how?