Can't access over home network

Started by Dasym, June 18, 2017, 02:22:58 PM

Previous topic - Next topic


I can access IMA using the WebViewer URL on the PC on which it is installed, but I can't access it from either a phone or a tablet on my network. If I use http://<server>:8081/imatchviewer the browser says DNS address could not be found. If I use httpL<IP address of PC on network>:8081/imatchviewer it gets somewhere: IMatch WebViewer appears as the title of the webpage but the page is completely blank.

I'd appreciate any suggestion on what I need to change on my home network to get this working.


If you want to access a computer over a network, the computer name must be resolved to the IP address. This is done via DNS server in your network - usually your router.
Do you by chance use Apple hardware? In that case, this won't work. Apple still does not support the required protocols for Windows networks.

You need to use the IP address of the computer running IMWS for both IMatch WebViewer (You did that already) and also in the config.json file which tells IMatch WebViewer where to find IMWS. The parameter imwsUrl in that file also must use the IP address and not the computer name (which is the default).

For more information, press <F1> in IMatch WebServices Controller to open the help. Then click on WebViewer Configuration in the menu at the top.

See also the IMatch Anywhere FAQ


No Apple stuff, and I don't seem to have a DNS server.

I've changed the config.json file but still get the same result. The browser page title changes to show IMatch WebViewer but the page is blank. This happens if I use the IP address in the URL on a tablet or phone on the network or in a browser on the same computer as IMatch. In fact, the same thing happens now if I use the computer name on the local PC.

The IMatch WebViewer link displayed in the Controller is still http://<computer name>:8081/imatchviewer. If I click on that the browser on the PC opens the web viewer and I can see my photos. The URL in the address bar, however, is http://<computer name>:8081/imatchviewer/#/imatch. So I typed into the browser http://<ip address>:8081/imatchviewer/#/imatch. This works on both the local PC and on a tablet on the network.

So I can now use the IMatch Webviewer, but not with the expected link.


QuoteSo I typed into the browser http://<ip address>:8081/imatchviewer/#/imatch. This works on both the local PC and on a tablet on the network.

Yes, this is what I tried to say above. If your device cannot resolve the computer name, you need to use the IP address to access IMatch WebViewer in your browser. And the imwsUrl in the config.json configuration file must also use the IP address so IMatch WebViewer knows how to contact the computer running IMatch WebServices.

If you are using Android devices, the problem could be that Google always prefers its own DNS servers, thus not using the DNS server in your network.

The check if there is a DNS server in your Windows network you can follow the instructions in the IMatch Anywhere FAQ:
Scroll down to the headline Does Your Network Run a DNS Server? The command listed there will show you if and on which device the DNS service runs.


I think I follow that. I don't understand why I need to put /#imatch after http://<ip address>:8081/imatchviewer to get it to work, but it's working well with that link. Must be something strange about my network setup.

Thanks for all the help.


Always put in an / at the end. URLs must end with a / or the web server may get the wrong idea:

http://<ip address>:8081/imatchviewer/