Strange behavior of Database Error warning on different PCs

Started by Lucio.B, January 20, 2023, 11:41:39 AM

Previous topic - Next topic

Lucio.B

Since 10 days i have problems with the database.
I use Imatch on my desktop and on my laptop and the issue showed up on my laptop, except the last time today.
I store all images and related files on an external drive along with the database, after the first issues I bought a new external NVMe drive but it didn't solve. I keep two updated manual backups of the whole images drive on 2 external drives and 2 separate automatic daily backups, of the database only, on the two pcs internal drives.

Issues on my laptop
Lately I very often have a "Damaged Database" warning on my laptop, running the diagnosis tool the damage results unrecoverable and I have to restore it from the backups.
Today i had a "Damaged database" warning on my desktop too so I restored the database from the yesyerday backup fron the internal desktop drive.

After that I opened the database on the Desktop and everything was ok.
Then I opened the same database on the laptop and it resulted damaged. I made a fresh installation of Imatch, tried to reopen but no success, same error.

Going back to the desktop and opening the same database from the same drive everithing sounds ok. (???)
Returning to the laptop same error. After this I've repeated 3-4 times the same procedure and nothing change. Problem on Laptop, ok on desktop.

After that I ran the diagnosis tool on the same database file on both pcs and I collected the log files. I collected also the application logs after opening the same database file without doing any further operation. I send you both couples of files (laptop and desktop is specified in the file name)

Could it be a hardware problem? A windows issue?

Thanks Mario, now is up to you ;)

Mario

The database system reports Physical database damage: 'database disk image is malformed', which is something I usually only see when a database was damaged by a power failure, a Windows hard crash or when users use a shaky network or a bad external disk to contain the database file.

How do you transfer the database to your laptop?
Network? External disk? WiFi?

It seems to me that the database file gets damaged during transfer.

Lucio.B

I had an external usb hard disk and now a NVMe usb.
I can add two more logs I had after tring to Pack and Go the database.
This time had this error on the desktop, perhaps the database file was alredy corrupted.

Mario

QuoteI had an external usb hard disk and now a NVMe usb.
Try another cable. Crappy cables are often the cause for such problems.

Pack and go reports: Diagnosis failed. Database system reports phyical damage to the database file.
Same problem.

Damaged databases are super rare. The only known reasons for corrupted databases is physical damage to the database file, e.g. during a power failure or crash while Windows is writing to the disk or similar.

Since this happened never before but happens now for the past 10 days,
it is very likely that an external source is the problem. Virus checker blocking IMatch in the middle of writing to the database. Malware encrypting files or damaging them. Hardware defect...
Database restored from backup working file but becoming corrupted again.

Check the Windows Event Log for hardware-related error messages. Run a virus check.
Try to recall what has changed 10 days ago.

Lucio.B

Hardware problem.
Searching the internet i've found that there is a known issue of the motherboard's chipset AMD B550 of my desktop, so the database is damaged while the external NVMe is attached to the desktop and not to the laptop as I thought. The issue shows as a rapid, random and repeated disconnection/connection of the USB ports It randomly appears in some PCs (so far some thousands).
Regards.

Mario

Yikes! How unfortunate  
Hopefully there is a firmware/BIOS fix for this.

Lucio.B

Unfortunately at present there's no driver patch.
The only workaround is to switch in the BIOS from PCIe GEN4 to GEN3 and don't use the 3.0 USB ports with 3.0 usb devices, infact if you attach a 2.0 device everything runs smooth or install an USB card, both solutions aren't really exciting.
This is the worst hardaware bug i've ever encountered since I started using a PC.
Good to know for anybody assembling a new PC.
Regards.