My changes of CreateDate are overwritten on next write-back

Started by PapaGei, December 10, 2022, 11:20:54 AM

Previous topic - Next topic


After a lot of tests and searching here I am confused:
I have got a .RW2 file from a Lumix camera, where I wanted to change "Create Date" and "Date Subject Created". When I change with TimeWiz or manually in Metadata panel and write-back changes, everything is fine.
But when I change, let's say Rating, later and write-back again, "Create Date" and "Date Subject Created" contain original/previous value and my changes are lost ?

I even tried to delete XMP data from .RW2, as it contains an embedded XMP record, but behaviour did not change.

Maybe someone has a hint, or is this a bug ?


I assume you use the default metadata settings in IMatch? If you have changed something on Edit > Preferences > Metadata 2, let us know.

An embedded XMP record in the RAW will mess up things.
How did you try to delete it?
You can check with the The ExifTool Command Processor (<F9>, <E>) if the RW2 file contains XMP metadata. Run the "List Metadata" preset and then search for XMP.

When you change date and time information in the Metadata Panel and write back, IMatch will synchronize these two time stamps into the corresponding EXIF timestamps in the RAW file. This way, both XMP and EXIF contain the same data, which is important.

Make a test.

1. For a test file, change the date subject created to "2022:12:10 12:11:10" and date subject created to "2022:12:10 10:11:12". This gives you to easy to identify timestamps.

2. Open the Output panel (View menu > Panels)

3. Write-back

4. Check the ExifTool output panel for warnings or error messages.
If ExifTool runs into problems updating the RAW file, detailed info will show here.

5. Run the "List Metadata" preset in the ExifTool for the RAW file. Search for the two timestamps. They should exist in the EXIF record of the file.

6. Switch to the "List Metadata in XMP Files" preset and let it run. This shows the data in the XMP file for the RAW.
The two timestamps should exist here as well.

7. Run the Metadata Analyst app on the RAW file so check it for problems. Use the GREEN BUTTON at the top to copy/paste the warnings and errors in your reply.

The only reason I see for this to happen is when ExifTool fails to update the metadata in the file, leaving the EXIF timestamps unmodified. When you write-back the second time, the metadata in the file is re-imported, resetting the timestamps to whatever is stored in EXIF.


Thx for very quick reply,

Changed settings in Edit > Preferences > Metadata 2 (german version):
  • Bewertung und Beschriftung schützen=Ja
  • Zeitzone anwenden=Nein

Concerning the delete: In ExifTool Command Processor is a template called "XMP-Metadaten löschen" (german version), which does the job.

I did the test steps you suggested:
4. no error or warning
C:\Program Files\\imatch6\arg_files\exif2xmp.args
C:\Program Files\\imatch6\arg_files\iptc2xmp.args
C:\Program Files\\imatch6\arg_files\gps2xmp.args

-XMP-photoshop:DateCreated=2022:12:10 10:11:12
-XMP-exif:DateTimeOriginal=2022:12:10 10:11:12
-XMP-xmp:CreateDate=2022:12:10 12:11:10


    1 image files updated

----- Runtime: 1 s.

5. my timestamps are not there, I searched for 2022:12:10 and got
[System]        File Modification Date/Time     : 2022:12:10 10:12:54+01:00
[System]        File Access Date/Time           : 2022:12:10 13:42:15+01:00

6. my timestamps are there, found lines for 2022:12:10
[System]        File Modification Date/Time     : 2022:12:10 13:42:08+01:00
[System]        File Access Date/Time           : 2022:12:10 13:42:14+01:00
[XMP-exif]      Date/Time Original              : 2022:12:10 10:11:12
[XMP-photoshop] Date Created                    : 2022:12:10 10:11:12
[XMP-xmp]       Create Date                     : 2022:12:10 12:11:10
[XMP-xmp]       Metadata Date                   : 2022:12:10 13:42:08+01:00
[XMP-xmp]       Modify Date                     : 2022:12:10 13:42:08+01:00

7. output of Metadata Analyst
Metadata Analyst Results. Version 2021.18.4. 10.12.2022 14:00:51
File analyzed: C:\Daten\FotosVideos\2022\Italien\20220901-P1002004.RW2
Errors: 0
Warnings: 10

Warning: [GPS] Altitude missing.
Warning: [XMP] XMP-exif GPS Altitude missing.
Warning: [XMP] [ExifIFD]:DateTimeOriginal and [XMP-exif]:DateTimeOriginal (sidecar) mismatch.
Warning: [XMP] [ExifIFD]:CreateDate and [XMP-xmp]:CreateDate (sidecar) mismatch.
Warning: [XMP] [ExifIFD]:DateTimeOriginal and [XMP-photoshop]:DateCreated (sidecar) mismatch.
Warning: [Detailed Validation] [minor] Non-standard EXIF at TIFF-IFD0-JPEG-APP1-IFD0
Warning: [Detailed Validation] [minor] Undefined value for MakerNotes:ClearRetouchValue
Warning: [Detailed Validation] [minor] Unknown value for GPS:GPSMeasureMode
Warning: [Detailed Validation] IFD0:StripByteCounts is zero
Warning: [Detailed Validation] IFD0:StripOffsets is invalid (0xffffffff)

I did the test with a raw file where I deleted the embedded XMP record, see above.

So apparently the problem is, that ExifTool does not write time stamps into raw file !?



The output showed me that IMatch did not ask ExifTool to synchronize metadata from XMP back into EXIF.
This is what is causing the problem.

Looking at the file-format metadata settings for RW2 under Edit menu > Preferences > Metadata 2: File Formats showed that writing of EXIF and IPTC is off by default. The defaults come from a metadata configuration file IMatch maintains.

Looking at the ExifTool web site ( for RW2 reveals that ExifTool (now?) supports writing for EXIF/IPTC for the RW2 format.

I have no documentation but maybe this was not enabled for RW2 files at some time and I never updated the configuration file. Or it is a copy & paste error that showed up for the first time with your files. I don't know.

I have made some tests with RW2 files in my test suite and updating EXIF works fine. The files are still readable afterwards in various RAW processors I've tried, including Adobe's ACR and Lightroom.

I have thus changed the default settings for RW2 and related formats to write EXIF/IPTC.

Your work-around:

Open Edit menu > Preferences > Metadata 2.
Click on the "Configure File Formats..." button.
In the list, scroll down until you reach .RW2  (Press <R> once to scroll down to file formats starting with R).
Disable "Use default settings" and Switch "Write IPTC" to "Yes" and "Write EXIF" to "Yes".
Close the dialog with OK.

IMatch will now synchronize XMP into EXIF and IPTC (if the file has IPTC data).
Change the time stamps again in the MD panel and write back.
Change the rating and write back.
The timestamps should stick now.

When you use the ExifTool Command Processor for the RAW, you should see the updated timestamps there as well.


Hey Mario,

good job, this change in configuration solved my problem.

Thx a lot  :)