problem running exiftool

Started by deaded, August 30, 2022, 10:56:04 PM

Previous topic - Next topic

deaded

I've had iMatch for a couple of years but today for the first time I get this error and can't figure out how to fix it.  I didn't find anything searching google or this forum.  I tried downloaded a new exiftool.exe but it didn't change anything.  The error message says to repair it in Control Panel but how?  I opened control panel, there is no repair option (I'm using the latest Windows 11).  I tried going to Settings->apps->apps & features and clicking iMatch but there is no repair option so I have no idea what they are talking about. 

Help please!


Mario

Unfortunately, Microsoft is removing useful features from Windows, for unknown reasons. Like the ability of Windows Installer to re-install a software (in this case IMatch) to repair damage done.
This was a feature automatically provided by Windows installer, but now it seems that this is no longer available for some Windows 11 editions in some areas. Don't know why, sorry.

You did not include a log file (see log file) so I don't know details about the error.
From experience, my guess would be that you virus checker has decided to delete ExifTool or some of the component it uses. And this is why IMatch cannot longer run it. Happens, occasionally. For whatever reason. Depends on the AV you are using. Did you get any message from your virus checker? Does it has moved exiftool.exe info "quarantine" (or whatever your virus-checker calls this)?

False positives are becoming a problem these days. Since Windows Defender (built into Windows) has become so good, the anti virus vendors try to be "better" to justify the cost, causing problems along the way...

You can always download and re-install IMatch from the customer portal (https://www.photools.com/customer/). Installing the latest version will also re-install all missing components and ExifTool.
It might happen that your virus checker is deleting ExifTool again (for whatever reason). In that case, please contact the support of your anti-virus solution for help.
Usually you would make the ExifTool.exe application in the IMatch program folder (c:\program files\photools.com\IMatch\...) an exception in your AV solution.

Note that the file has been signed by me with my code-signing certificate and that you can check if exiftool.exe is valid by right-clicking on the file in Windows Explorer > Properties > Digital Signatures. Windows would warn you if the certificate is invalid due to a modification on the exiftool.exe.

deaded

#2
No, not the virus checker.  I keep it on a very short leash and I'm certain.  Like I said, I reinstalled exiftool but nothing changed so maybe you're right about one of it's components being deleted because the only way I could figure out how to reinstall it was with the -k option.   I see there is a non critical windows update pending, doesn't seem to have anything to do with iMatch but will install it and re-install iMatch.

--edit--

Ah, yes!  It was either the windows update (doubt it) or the re-install of iMatch (most likely). 

Thank you very much for your help.  I did have to select and update the ones it had a problem with but that was pretty easy and only took a minute.  Everything is back to normal!

Oh, and Mario, NICE response time!!

Thanks again,
Ed

Mario

Good news!

Pending or stuck Windows updates sometimes cause strange issues.
Since Windows no longer really reboots but hibernates instead, 'stuff' can pile up and then causing problems.
Letting it finish the update, or just the following reboot, may have fixed the issue. I cannot tell.

In the past, when a user reported that he/she suddenly gets this ExifTool panic message from IMatch, the reason was a virus checker which quarantined or even silently deleted ExifTool or one of the components it relies on.