Author Topic: change imatch viewer multi-view work like lightroom and capture one  (Read 153 times)

chupacabra

  • New Members
  • *
  • Posts: 16
in lightroom and capture one, the number of images you see in the Viewer is always the number of images selected in the main window. There is no "L"<number> setting like in imatch. If I select three images in the main window and bring up the viewer, I see three images. If I close the Viewer and select one image in the main window and bring up the viewer again, it displays one image. This is also true of capture one.

in order to display multiple images in the viewer you must first select "L"<number> in the Viewer. from then on imatch will always try to display that many images in the viewer.  If I select one file in imatch and bring up the viewer after having previously selected "L3' to view three images, imatch will still display three images in the Viewer even though I had only selected one image in the viewer. In order to view only one image in the viewer you must bring up the viewer and select "L1".

In lightroom and capture one, there is no equivalent to the "L"<number>" selection in imatch. however many images you have selected in the viewer is the number of images shown in the Viewer. Select three images, bring up the viewer, and you see three images. Close the viewer, select one image, bring up the viewer and you see one image. It's very WSYSWIG.

Sometimes I want to compare two or three images side-by-side in imatch so I select my images, bring up the viewer, and type "L3" to see my three images, then close the Viewer. I may next want to see only one large image in the viewer rather than three smaller images so I select my image, bring up the viewer, and it displays three images. I have to type "L1" to get it to show only the image I requested.


Mees Dekker

  • Translators
  • *
  • Posts: 521
  • Mees
-1

I'm very happy with the way it is. I often select 10 or more pictures to be shown in the viewer and I certainly don't want to have them all in one screen.

Mario

  • IMatch Developer
  • Administrator
  • *****
  • Posts: 28225
This is an "up to" setting.

If you set this the Viewer to show 4 files, but you later open the Viewer with only two 2 files selected, the Viewer will display these 2 files only.

Quote
after having previously selected "L3' to view three images, imatch will still display three images in the Viewer even though I had only selected one image in the viewer.

By default, opening the Viewer when having only one file selected opens all files in the File Window.
If you don't want this, disable the corresponding option under Edit > Preferences > Application: Viewer.
Search for loads all to find single selection loads all files and set this to 'No'.

Now, when you have only one file selected and open the Viewer, the Viewer loads only this one file.

Carlo Didier

  • Super Hero
  • ****
  • Posts: 1665
+1 for me. I'd also prefer the behvior from LR, C1, etc.

thrinn

  • Hero Member
  • ***
  • Posts: 932
I'm very happy with the way it is. I often select 10 or more pictures to be shown in the viewer and I certainly don't want to have them all in one screen.
Same for me. I like the way IMatch handles it now. Therefore:

-1

Thorsten
Win 10 / 64, IMatch 2018, IMA

Mario

  • IMatch Developer
  • Administrator
  • *****
  • Posts: 28225
The OP should then just set <L>,<8> to always get a maximum of 8 files.
When he now only selects 3 files, he sees 3 files in the Viewer. If he selects 6 files, he sees 6. And if only one file is selected, he sees one file (unless the option "Opening the Viewer with one file selected opens all files in scope").

I don't see a need to change anything - it already works for all users, right?
The layout setting in the Viewer is an up-to setting, so every user can dial in what works best for her/him.

sinus

  • Global Moderator
  • *****
  • Posts: 4313
  • IMatch-User since 2001 (IMatch 3.6)
-1

for me it works fine, like it is now.
Best wishes from Switzerland! :-)
Markus