Author Topic: [IMA2019] No keywords on mobile device  (Read 602 times)

Rene Toepfer

  • Jr. Member
  • *
  • Posts: 53
[IMA2019] No keywords on mobile device
« on: April 11, 2021, 09:38:16 AM »
When I was searching the keywords I have figured out that keywords will not be shown on my mobile device (Google Pixel 3 XL).
Please look at the attached screen grabs. On win10_chrome.png can be seen that the keyword will be filtered correct at my workstation. If I do the same at my Pixel no keyword containing the search string will be found, see attachements android11_chrome_desktop_mode.png and android11_chrome_mobile_mode.png. It does not matter if I am in mobile or desktop mode at my Pixel.
In all cases the latest revision of Chrome has been used.

Mario

  • IMatch Developer
  • Administrator
  • *****
  • Posts: 29481
Re: [IMA2019] No keywords on mobile device
« Reply #1 on: April 11, 2021, 10:57:32 AM »
I don't have a Google Pixel device to test this. May be a bug in Chrome on that platform, or the Android version or who knows what.
Impossible to tell without actually renting or buying exactly the device you are using, with exactly the same version of Chrome and Android.

Does your Pixel allow you to enable the developers tools for Chrome (via the menu)? If so, are there any error messages or warnings listed in the console when you refresh the UI?

When I simulate the Pixel XL in Chrome or use a Pixel Simulate, the WebViewer works normal. Search works for Keyword as well as the buttons.
« Last Edit: April 11, 2021, 11:14:08 AM by Mario »

Rene Toepfer

  • Jr. Member
  • *
  • Posts: 53
Re: [IMA2019] No keywords on mobile device
« Reply #2 on: April 12, 2021, 01:00:13 PM »
There is no error message on my mobile. I have tried also with my Samsung Galaxy Tab S5e as well as a Samsung Galaxy A3 of my neighbour and the keywords will also not be shown on these mobiles. What I was figuring out, is that the language of the login interface is English instead of German while on desktop it is completely in German language. IMWS is set in German language and it works fine on desktop.

Unfortunatelly I cannot create any log on my mobile devices.

Mario

  • IMatch Developer
  • Administrator
  • *****
  • Posts: 29481
Re: [IMA2019] No keywords on mobile device
« Reply #3 on: April 12, 2021, 01:45:53 PM »
I always test in English and German.
Are your keywords in the neutral language (default in IMatch)?
The UI language of the WebViewer is a per-user setting you control in the WebViewer options.

Do the Keyword buttons work?
In your example, there seems to be no keyword starting with B (no "B" button) but you search for "Ball"...?
Not sure if this makes a difference. Are any keywords shown when you click on one of the buttons?
« Last Edit: April 12, 2021, 01:48:27 PM by Mario »

Rene Toepfer

  • Jr. Member
  • *
  • Posts: 53
Re: [IMA2019] No keywords on mobile device
« Reply #4 on: April 12, 2021, 02:03:46 PM »
I do not mean the language afterwards login in but the login interface itself. On desktop it is German language (as I have set in IMWS). If I load the login interface on my mobile devices it is in English language.

The keyword buttons do not work. I tried to use "Alle anzeigen" to get the complete list but nothing happens. The same applies for all other letters.
I also renamed the "_Schlüsselwörter" to "Schluesselwoerter" - nothing changed.

Mario

  • IMatch Developer
  • Administrator
  • *****
  • Posts: 29481
Re: [IMA2019] No keywords on mobile device
« Reply #5 on: April 12, 2021, 02:24:20 PM »
The UI language can be set in the WebViewer configuration.
I also see you have a recent setting enabled. Maybe clear it once to clean the scope.
Do other navigator items work, like folder or category or other metadata?

Rene Toepfer

  • Jr. Member
  • *
  • Posts: 53
Re: [IMA2019] No keywords on mobile device
« Reply #6 on: April 13, 2021, 01:04:53 PM »
I also see you have a recent setting enabled. Maybe clear it once to clean the scope.
Do other navigator items work, like folder or category or other metadata?

I cleared all settings by clicking the X. Folder works as expected, I can browse all directories on my mobile. Categories are also working.

Could we try to reset the IMWS completely? What files/folders need to be deleted (or renamed)? Maybe there is a broken configuration.

Mario

  • IMatch Developer
  • Administrator
  • *****
  • Posts: 29481
Re: [IMA2019] No keywords on mobile device
« Reply #7 on: April 13, 2021, 01:28:45 PM »
There cannot be a broken configuration.
Have you tried searching other tags (not just keywords)?

Why does the browser on your Pixel does not support developer options? This is usually standard.
A look at the console or the network tab could reveal errors or warnings which cause this. This would be very helpful.

Rene Toepfer

  • Jr. Member
  • *
  • Posts: 53
Re: [IMA2019] No keywords on mobile device
« Reply #8 on: April 13, 2021, 03:10:32 PM »
Have you tried searching other tags (not just keywords)?
Yes, I have several categories "Calender 2022", "Ballet Audition" etc. and images tagged with these catagories will be shown if I select the related category.

Why does the browser on your Pixel does not support developer options? This is usually standard.
Chrome on Android has a hidden "developer option" which only traces but has no interface like on Windows/MacOS. As far as I understand the tracing can only be read with the Android SDK.

A look at the console or the network tab could reveal errors or warnings which cause this. This would be very helpful.
I know and believe me, I would submit them to you if I could.

Mario

  • IMatch Developer
  • Administrator
  • *****
  • Posts: 29481
Re: [IMA2019] No keywords on mobile device
« Reply #9 on: April 13, 2021, 03:37:50 PM »
I don't meant categories, I meant other metadata tags like title, description, headline etc.
These use the same code as keywords, basically.
Categories are separate.

All this is guesswork unless I get my hands on the same Pixel model, with the same Android etc.
Which will not happen, most likely.

Have you tried using another web browser, e.g. FireFox?

If you have purchased a HOME version, I can offer you a refund of the 50€.
This is cheaper for me than buying a Pixel and spending days trying to figure this out.
« Last Edit: April 13, 2021, 03:40:14 PM by Mario »

Rene Toepfer

  • Jr. Member
  • *
  • Posts: 53
Re: [IMA2019] No keywords on mobile device
« Reply #10 on: April 13, 2021, 06:28:47 PM »
I don't meant categories, I meant other metadata tags like title, description, headline etc.
These use the same code as keywords, basically.

These are working fine. I used "Suchen" with checked Metadaten

Have you tried using another web browser, e.g. FireFox?
I have installed Firefox on Android and IMA works fine with that. It seems that it is an issue with Chrome (current release: 89) on Android.

At the desktop it works fine and will be used by my two employees and me daily more and more (I run a PRO license). It's only for my work at my clients to use the access via my mobile devices. But now, we know that it is an issue with Chrome on Android and not IMWS/IMA. That's a good outcome of our evaluation IMHO. Therefore, we can close this issue because we found the reason for not properly working with Chrome on Android.

Mario

  • IMatch Developer
  • Administrator
  • *****
  • Posts: 29481
Re: [IMA2019] No keywords on mobile device
« Reply #11 on: April 13, 2021, 07:31:42 PM »
Well, that's at least something.
I always test FF and Chrome on all devices and simulators I have, also on Linux and Edge on Windows, too.

The problem with Browsers is that they change so fast. Updates are installed often, and sometimes they break something.
Or something that used to work no longer works, but only on a specific Android or iOS device or only in a specific browser version or a screen size (!).

Rene Toepfer

  • Jr. Member
  • *
  • Posts: 53
Re: [IMA2019] No keywords on mobile device
« Reply #12 on: April 13, 2021, 07:41:26 PM »
The problem with Browsers is that they change so fast. Updates are installed often, and sometimes they break something.
Or something that used to work no longer works, but only on a specific Android or iOS device or only in a specific browser version or a screen size (!).

Yeap, I absolutely agree!