Date/Time Metadata Problem Leftover from Old Software

Started by jch2103, April 15, 2020, 02:18:17 AM

Previous topic - Next topic


I've been cleaning up various metadata problems in old files that were written to by previously used programs. I've run into a date/time problem with certain images where Exif::\36867\DateTimeOriginal\0 has gotten 'stuck' with an incorrect date that I'm not able to change with a metadata panel (it shows that EXIF tag as not being writeable). I have no problem changing other date/times in the file, but this one tag is causing the images to sort in the wrong sequence. Attached is a Metadata Analyst report for one of the files, along with a reduced-size Zipped copy of the image. I've tried various things, including copying and editing the image, but no success in fixing the date/time tag.

Any suggestions?


What is the problem?

I've added the file to an IMatch database.
The file shows a date from 2004.

I change the created / subject created to the current date and time in the Metadata Panel.
I let IMatch write back.
The date and time sticks.

I check in the ECP and see:

[System]        File Modification Date/Time     : 2020:04:15 19:37:13+02:00
[System]        File Access Date/Time           : 2020:04:15 19:37:13+02:00
[System]        File Creation Date/Time         : 2020:04:14 17:58:08+02:00
[IFD0]          Modify Date                     : 2020:04:15 19:37:12
[ExifIFD]       Date/Time Original              : 2020:04:15 19:37:04
[ExifIFD]       Create Date                     : 2020:04:15 19:37:04
[Minolta]       Minolta Date                    : 2004:07:31
[XMP-exif]      Date/Time Original              : 2020:04:15 19:37:04.00+02:00
[XMP-photoshop] Date Created                    : 2020:04:15 19:37:04.00+02:00
[XMP-xmp]       Create Date                     : 2020:04:15 19:37:04.00+02:00
[XMP-xmp]       Metadata Date                   : 2020:04:15 19:37:12+02:00
[XMP-xmp]       Modify Date                     : 2020:04:15 19:37:12+02:00

which looks fine for me. Except for the proprietary "Minolta Date" all timestamps have been updated and are in-sync. My timezone is +02:00 currently.
-- Mario
IMatch Developer
Forum Administrator  -  Contact & Support - Follow me on 𝕏 - Like on Facebook


I'm having this problem with just some of the files I've been working on. For these files, I change the Composite Date Subject Created to the correct 2004:07:31 13:04:15 and save the changes, then rescan the image. EXP reports:

Quote[System]        File Modification Date/Time     : 2020:04:14 18:08:38-06:00
[System]        File Access Date/Time           : 2020:04:14 18:08:38-06:00
[System]        File Creation Date/Time         : 2018:03:19 23:45:38-06:00
[IFD0]          Modify Date                     : 2020:04:14 18:08:37
[ExifIFD]       Date/Time Original              : 2004:01:04 15:00:00
[ExifIFD]       Create Date                     : 2004:07:31 13:04:15
[Minolta]       Minolta Date                    : 2004:07:31
[Minolta]       Minolta Time                    : 13:04:15
[XMP-photoshop] Date Created                    : 2004:01:04 15:00
[XMP-xmp]       Metadata Date                   : 2020:04:14 18:08:37-06:00
[Composite]     Modify Date                     : 2020:04:14 18:08:37-06:00

That is, the incorrect 2004:01:04 15:00:00 keeps reappearing (following a rescan) after I change the date/time to the correct 2004:07:31 13:04:15. (In this case, the proprietary Minolta date/time is correct.) This only happens for some of the images I've seen working on.

I've now discovered that if I copy a problem image and make changes (you have a copied image), correcting the date/time works properly! It appears that rewriting the images fixes some internal issue; now I just have to copy and update all of the problem images... As I've said before, it takes a program like IMatch to reveal (and fix) hidden metadata messes!

After further investigation, for these files, I have to manually copy Created Date to Date Subject Created (even though both dates appear correct in the Metadata Panel) in order to get Exif::\36867\DateTimeOriginal\0 to 'take' the correct date.

(I should be able to just click the pen for Date Subject Created and write the change - the pen shows XMP::Photoshop\DateCreated whether I manually copy the tag or I just click the Date Subject Create tag pen, but the manual tag copy works while the tag write pen doesn't, if that's clear...?!)

So, it appears I have a way to solve the metadata problem, if an inelegant one.

Related, perhaps: Do you know what these messages from the Metadata Analyst report mean?
QuoteDetailed Validation
[minor] MakerNotes:PreviewImageStart is past end of file
ExifIFD tag 0x9010 OffsetTime requires ExifVersion 0231 or higher



Why do you change the composite tag? Why not change the XMP date created / subject created and let IMatch take core for the rest?

These warnings just tell you that the preview image in the file is messed up (probably an application has damaged the maker notes) and that the EXIF version stamp does not match what's in the file. Welcome to metadata mess.

I would consider deleting all the EXIF junk in ECP and let IMatch write a new one during write-back.
-- Mario
IMatch Developer
Forum Administrator  -  Contact & Support - Follow me on 𝕏 - Like on Facebook


You're right of course: I should be writing directly to the XMP tags rather than using composite tags. However, in this case the results are the same.

I'm copying by hand from one tag to another because my preferred option, using a Metadata Template, doesn't work even though it should be able to do the same thing. Attached is my Metadata Template for doing exactly what I'm doing manually on a file-by-file basis. If I use this template, the screen blinks but the value for Exif::\36867\DateTimeOriginal\0 doesn't change even after a write-back. But if I copy the same tags manually, the Exif tag does change to match the copied value (the desired result).

I also tried deleting both the Exif (Exif::\36867\DateTimeOriginal\0) and XMP (XMP::exif\DateTimeOriginal\DateTimeOriginal\0) tags with a metadata template (attached screen shot). However, the 'wrong' date/time keeps coming back!

I've run out of ways to do this except for manual copying of the needed tags... No doubt this is all because the files in question are quite messed up, but because they hold sentimental value I need to 'fix' them.


I've just updated the XMP tags in the MD panel and after writing back the file, all was well.
-- Mario
IMatch Developer
Forum Administrator  -  Contact & Support - Follow me on 𝕏 - Like on Facebook


I think that the process of resizing and re-saving the image that I sent you cleaned it up a bit so you were able to successfully change the tags. The images I have here had problems with had some kind of deep-seated issues that only a manual copy/paste of metadata tags was able to fix.

I've cleaned up all (I hope!) of the problem images (at least from that particular set). One more item off my to-do list.