IMatch Discussion Boards => General Discussion and Questions => Topic started by: vbt on January 14, 2020, 10:50:25 PM

Title: Filter Panel Problem
Post by: vbt on January 14, 2020, 10:50:25 PM
I have imported a number of photos and the jpg photos are correctly shown as versions of the raw files. (They have the correct icons, appear in the version panel if the corresponding master file is selected, and appear under Collections|Relations|Version.)

However if, in the filter panel, I select hide versions it doesn't work and the versions are still shown. If I click on another folder, without changing anything in the filter panel then the versions in that folder are hidden. So I do have the filter panel set up correctly. (Orange filter panel is ticked, file properties is ticked and Hide Versions is ticked. I clicked on the icon with the green arrow and filter and the blue banner is shown on top of the panel with all thumbnails.) But if I hide masters in the same folder that does work.

I have selected all the files in the problem folder and hit cntl+shift+F5 and even rebooted my PC.

Am I missing something, perhaps obvious?

Or could the problem be something to do with the fact that I have a series of version relations (set in preferences)? However to try and test that possibility I unselected all the various relations but one, then refreshed the relations for that folder's pictures but that still didn't work. (I did not refreshed the relations for all files in my database as that would take a lot of time just to test a possibility.)

Any ideas what is going on? How does the filter panel determine whether or not a file is a version? Does  it use a different method from that used to determine whether a file has a version icon, or appears in the version panel (when appropriate) etc.
Title: Re: Filter Panel Problem
Post by: Mario on January 15, 2020, 08:49:21 AM
Maybe the versions in that folder are masters too? Did you check that?

Any warnings (W>) or errors (E>) reported in the log file (
Title: Re: Filter Panel Problem
Post by: vbt on January 15, 2020, 11:25:40 AM
I have now checked the log file and there are no errors and the only warning seems unrelated:
"Spelling: Cannot find a dictionary for language 'en' or failed to load.  'v:\develop\imatch5\src\imatchng\imatch.cpp(3687)'"

The files should not be master files, don't show the master icon and aren't hidden if I hide the master files in the filter panel. But in any event would that account for the behaviour being seen? In other words if a file is both a master and a version file should it not then behave in the filter panel as both a master and a version file rather than as neither.

I have also come across a further problem which I mention just in case it is related, although I think it unlikely. There is a file that won't be moved by IMatch, saying it is being used by another process. However if I close IMatch I can move the file with windows explorer. I then move it back and try again in IMatch and still get the same problem. But that file is the one file in this folder that doesn't actually have the problem with it not being able to be hidden as a version by the filter panel.

Is the process used by the filter panel for identifying version files different from that used elsewhere because when I select all the files in the folder and toggle the version stack then all version files are correctly hidden?
Title: Re: Filter Panel Problem
Post by: Mario on January 15, 2020, 11:54:31 AM
There are many reasons why a file can can be locked.
What kind of file? What format?

Has IMatch finished processing the file? Still in the queue perhaps?

The only thing in IMatch that could "lock" a file would be a Windows WIC codec.
This can happen occasionally (RAW files) but only Microsoft can solve this. I have seen this once or twice over the years.

Maybe ExifTool may lock a file while it is reading or writing it.
IMatch does not lock files by itself, it has no need for this.
Another typical reason for this is a virus checker interfering. Happens where often these days.

I have no idea why the Filter Panel is not working for your one folder.
No similar reports. If other folders with other files work with the same filter, there must be something special only with these files.
Refresh the relations. Make sure you don't nest masters and versions or create chains.
If you hide versions and a version is also a master it of course will not be hidden.
Title: Re: Filter Panel Problem
Post by: vbt on January 15, 2020, 12:07:51 PM
I will ignore the problem with the locked file if it is not related then it is a red herring at the moment.

However I would like to know what is causing the problem with the filter panel.

You say don't create chains. At the moment I removed the chains I did have and refreshed the relations in that folder. However could that still be the underlying cause? What does the filter command actually rely on? Is it a different item of data from that used elsewhere? If so then I can just not use the filter panel's version filters. However I am concerned the issue may affect other version functionality.

Title: Re: Filter Panel Problem
Post by: Mario on January 15, 2020, 01:16:05 PM
The filter command uses the same data as all other version-related features in IMatch.
If it only fails for the files in one folder, and only on your system and with your database and setup, the only way to track this down would be to carefully analyze your database, all affected files, how you have setup versioning, what this causes in the database etc. Very time consuming and I would need your database in my lab. And currently my only priority is getting IMatch 2020 out to the user base.

If this issue even survives a complete relation rebuild, try to disable each relation rule, rebuild.
Add one relation back and rebuild. Check if this affects the filter behavior for files in this folder.
Repeat if you have more than one relation rule.
Maybe this helps to figure this out.
Title: Re: Filter Panel Problem
Post by: vbt on January 15, 2020, 03:00:03 PM
OK I have taken off all my versioning preferences by unselecting them all in preferences (but did not delete them).

I then refreshed all relations and checked that all files were no longer classed as master or version.

I then activated one versioning rule (which only affects my most recent files) and again refreshed everything.

I then checked the files that should be master and versions were correctly identified and they were. (All are in the one folder.)

Then I tried filtering out the version files using the filter panel and it again failed, even although the versions are clearly highlighted with the correct icon.

So I set up a new test database with only the affected photos and added the one versioning rule. However in this database the versions are correctly being filtered by the filter panel.

So it seems something in my main IMatch database is surviving the refreshing of relations. (I did also ctl+shft+f5 all the recent files but not all my files as that would take a very long time to complete.)

Any idea what to do next?

Title: Re: Filter Panel Problem
Post by: hluxem on January 15, 2020, 03:06:22 PM
Just a week ago I experienced the same problem.
I have not reported the issue yet as I could not reproduce it, restarting Imatch and using a different filter method fixed it.

For me the problem showed using the "File Properties" filter, it also effected only one folder from several I was working on at the time.
I did take screen snapshots which clearly shows the issue, there was no change in file or database, just a restart of Imatch/Windows. I also saved the logfile, but there is nothing unusual in it. As my saved filters and using file properties did not show the right result, I deleted my saved filters and looked around for a different method. I tried the collection filter and that only failed me once. When it failed, I could go to the collection panel and it showed my database had 0 versions which is clearly wrong. Restarted Imatch and it showed the correct number of version and the filter worked again. This was similar to the filter issue I had with labels before. I have not seen the issues with labels anymore for a long time. (

I did just a short test to see if the 2 methods of filtering for versions do show the same result today. I selected 9071 files in the time line and used the "File Properties" filter, hide version and hide master selected. Result is 258 files shown, 209 are versions which should not be shown. All versions shown are from the same date, 2 different folders.
Next I use the "Collection Filter", selected combine files with or, selected relation, master and version and finally checked invert the result. 57 files are shown, neither one is a version.

Maybe the OP can try if the "Collection Filter" works correctly for him too.

I don't want to post my screen shots as they involve personal pictures, but I can share or email them to you if that helps. I know it's hard to fix a problem if you can't reproduce the issue, that's why I'm hesitant to post things when I'm not sure what is happening. Please let me know if there is anything I can do to get you more information.

Title: Re: Filter Panel Problem
Post by: Mario on January 15, 2020, 03:15:23 PM
Run a database diagnosis to make sure the DB is OK.

That a problem occurs only for one user and only for one database / PC is happens occasionally. But almost impossible to reproduce or fix.
Often not even having the same database here allows for reproducing the problem. Because it depends on the hardware or performance of the origin system. Or on the specific mix of other software, background services running, workspace layout, screen resolution etc. Which panels are open, for example, can affect this. Maybe the combination of panels causes IMatch to wait before it can update the collection, or even run into a timeout and re-schedule the collection update for a later time...

I could spent an entire week with such an issue, without any result.
While other things pile up in my inbox, here in the community and elsewhere.

When you can figure out under which conditions this happens, or you can reproduce it with a small test database without privacy issues which you can send me, I'll be happy to look into this. Everybody knows I hate bugs, especially in my software products.

I use versioning in my private databases and I have never seen this. But then, my database is different, my hardware is different, my settings are different, my hardware performs different, my workflow is different, the panels I have open is different etc.
Title: Re: Filter Panel Problem
Post by: vbt on January 15, 2020, 03:23:10 PM
hluxem - Thanks for the reply.

I just tried by collections and yes that does work for me too. So everything to do with versioning seems to work properly except for the file properties version filter. However a reboot of my pc has not fixed the file properties version filter.

Can I just check do you have more than one version rule that can apply to the same file? I did have this but it seemed to work the way described in the help files. That is it was the last version rule that "won". Although I have removed those version rules at the moment, to help trace the issue, I do wonder if they somehow caused a problem and that the problem has not been removed despite me since changing the versioning to just one rule.

Title: Re: Filter Panel Problem
Post by: vbt on January 15, 2020, 03:29:16 PM
Mario - just after I posting my reply I remembered to check the database diagnostics but that was clear.

It seems out of 75 views one other person has also had this problem. So not totally isolated.

That said I realise debugging is difficult but much more so if you don't know how the program is working. Clearly something must be being processed differently between the file properties filter section and other places, including even the collections filter section.